Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#11419 - Xorg 1.5 and artifacts

Attached to Project: Arch Linux
Opened by Francesco Antonacci (punkeroso) - Sunday, 07 September 2008, 17:35 GMT
Last edited by Jan de Groot (JGC) - Saturday, 13 September 2008, 12:07 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


I have been having these strange artifacts in gnome selecting icons on the desktop and in the scroll bar (only with a murrina theme). I think is 3D related...
I've attached a screenshot

xorg-server 1.5.0-1
nvidia 173.14.12-3
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 13 September 2008, 12:07 GMT
Reason for closing:  Fixed
Comment by Francesco Antonacci (punkeroso) - Sunday, 07 September 2008, 18:05 GMT
I tried to downgrade pixman to 0.11.8 and the artifacts disappeared.
Comment by Jan de Groot (JGC) - Sunday, 07 September 2008, 19:24 GMT
Try setting your depth to 24 or 32bpp. I can only reproduce this in Xephyr with 16bpp.
Comment by Francesco Antonacci (punkeroso) - Sunday, 07 September 2008, 19:43 GMT
I have the same issue on the eeepc and, also there, the DefaultDepth in the Screen section is set to 24.
Comment by Dan McGee (toofishes) - Sunday, 07 September 2008, 22:12 GMT
screen #0:
print screen: no
dimensions: 1440x900 pixels (411x263 millimeters)
resolution: 89x87 dots per inch
depths (7): 24, 1, 4, 8, 15, 16, 32
root window id: 0x5d
depth of root window: 24 planes

Seems to happen with a depth of 24. I'm using Clearlooks for a GTK theme; I can also reproduce it with Crux but not G26.
Comment by Jan de Groot (JGC) - Monday, 08 September 2008, 07:04 GMT
Dan, is this fixed by downgrading to 0.11.8 and restarting X?
If so, could you run some git bisect on pixman to find the bad commit?
Comment by Christophe (tolgam) - Monday, 08 September 2008, 13:32 GMT
I also have the same problems with the Nodoka engine/theme and 24bpp.
Did not yet tried to downgrade pixman.
Comment by Christophe (tolgam) - Monday, 08 September 2008, 15:00 GMT
Problem also solved using pixman 0.11.8 instead of 0.11.10
Comment by Jan de Groot (JGC) - Tuesday, 09 September 2008, 09:12 GMT Comment by Paul Bredbury (brebs) - Thursday, 11 September 2008, 14:17 GMT Comment by aidenn (idn) - Thursday, 11 September 2008, 14:44 GMT
Same here. 24bpp, no Compiz. I also have some strange black dashed lines on unselected form fields and progress bars everywhere (dunno if this is a separate bug, but it showed up together with selection box corruption after upgrading to 1.5). Attached a screenshot. The theme is Shiki-Wise, but it appears in pure Clearlooks too.
Comment by Christophe (tolgam) - Saturday, 13 September 2008, 07:43 GMT
Problem solved thanks to the patch.
Comment by Xavier (shining) - Saturday, 13 September 2008, 08:59 GMT
The patch works perfectly here too, thanks.