Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#11408 - grub-based installation iso drops to GRUB prompt

Attached to Project: Release Engineering
Opened by Jonathan Steel (jsteel) - Saturday, 06 September 2008, 12:08 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Friday, 05 March 2010, 18:15 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To Dieter Plaetinck (Dieter_be)
Architecture All
Severity Low
Priority Low
Reported Version 2009.02
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

2008.06 installation CD drops to GRUB prompt instead of displaying the different boot options on an Acer TravelMate 290.

I have seen this mentioned in the forums and with other distros. It seems that some laptops do not like live CDs that use GRUB. Live CDs that use ISOLINUX work. I have tried the ftp and core isos. I have tried downloading them via ftp, http and torrenting. I have tried buring the iso using a slower speed. I have checked the download using md5sum and have checked it again after burning the CD. The CDs are fine and work on other laptops. I have copied the boot parameters from the CD displayed correctly on a working laptop and typed them in on the non-working laptop. This did not help. Please can you provide an ISOLINUX version so we can install using the latest version; so we don't have to use an old iso?

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Boot any version of the 2008.06 installation CD on an Acer TravelMate 290.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Friday, 05 March 2010, 18:15 GMT
Reason for closing:  Upstream
Additional comments about closing:  We switched entirely to isolinux now.
(we needed to, to have isohybrid).
as a sideeffect, the grub problems are gone ;-)
Comment by Jonathan Steel (jsteel) - Saturday, 06 September 2008, 19:59 GMT
I found this similar bug from early 2007. It was said at the end that ISOLINUX would be used in the next release. Hopefully this will have the same outcome? Thanks.

http://bugs.archlinux.org/task/6292
Comment by Tobias Powalowski (tpowa) - Sunday, 07 September 2008, 07:14 GMT
you can still use the ISOs from march they use isolinux, ftp install is broken on them, but base install should work well.
Comment by Jonathan Steel (jsteel) - Sunday, 07 September 2008, 09:18 GMT
Yes that is a work around, but what about after the next release? And the next release? If GRUB is continued to be used in the future releases with no ISOLINUX alternative, then some people will have no option but to use an out-dated version to install. Newcomers will be put off when they download it and are unable to install it.
Comment by Tobias Powalowski (tpowa) - Sunday, 07 September 2008, 09:56 GMT
i'll continue to create archboot isos, so this will be an option. I already rewrite it, but it will need some time until it is finished.
Else aaron dan and simo need to change the live cd installer.
Comment by Pierre Schmitz (Pierre) - Sunday, 07 September 2008, 15:01 GMT
Do you know if this is a grub problem or just broken bios/cdrom/controllers?
Comment by Jonathan Steel (jsteel) - Sunday, 07 September 2008, 18:25 GMT
tpowa,
Thanks, will it appear on the mirrors when it is complete or will it be hosted elsewhere?

Pierre,
I have tested another Acer TravelMate 290, resulting in the same problem. I've heard this problem to occur on other Acer models.
Comment by Tobias Powalowski (tpowa) - Sunday, 07 September 2008, 19:35 GMT
yes i think i'll get the permission from aaron, as far as i know we decided to share them in the iso dir then.

grub had issues so i decided to revert back to isolinux which seemed to work better on certain boards.
Comment by Jonathan Steel (jsteel) - Sunday, 07 September 2008, 19:40 GMT
Great, thanks!
Comment by Aaron Griffin (phrakture) - Monday, 08 September 2008, 23:21 GMT
Just for the record, I have a lot of archiso changes being pushed soon. I am going to provide the option to use isolinux as well as grub for those people who have hardware that grub doesn't like
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 January 2009, 20:18 GMT
2009.01 will come in grub and isolinux flavors.
Comment by Gerhard Brauer (GerBra) - Tuesday, 27 January 2009, 12:38 GMT
For the upcoming ISOs we could do a research on this grub behaviour. I have a list with PCs from users which had similar problems using a cdrom with grub bootloader. Also found a patch from Fedora side where they maybe have solved this for their boot cdroms.
This bootloader part is on my ToDo for 2009.04. In the meanwhile users could use the isolinux cd.
Comment by Dieter Plaetinck (Dieter_be) - Wednesday, 24 June 2009, 17:27 GMT
- the problem is still there. Though only few people with specific (old?) hardware seem to have it.
- It's very hard to reproduce this, let alone fixing it. (this is more of an upstream issue)
- There is a grub2 which should not have this issue, but we could not get it to work properly for booting iso's.
- I believe I read somewhere upstream is not planning on patching this grub-legacy.
- We provide isolinux as a workaround.

So I suggest to keep this bug open. It's something that should be "fixed" at some point. But giving this very low priority because all of the above.
Comment by Robert Howard (iBertus) - Thursday, 13 August 2009, 01:30 GMT
I'm having this problem with my Skulltrail system and a pair of SATA Lite-On DVD-RW drives. My laptop which also has an Intel chipset does not have this problem. ISOLINUX images work without issue.
Comment by Aaron Griffin (phrakture) - Monday, 17 August 2009, 20:29 GMT
It might be worth looking into chaining other bootloaders for cases like this. Perhaps we could have grub try to use isolinux if things fail...
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 19 August 2009, 01:17 GMT
Aaron, how would that work? That would request patching of Grub itself, wouldn't it?
Comment by Aaron Griffin (phrakture) - Wednesday, 19 August 2009, 03:59 GMT
I thought it was possible. Grub's config file is pretty interesting. I think we might be able use 'chainloader' on a file, or something similar. I know this would work with USB drives, as we could install grub on the main drive, and isolinux on a partition...

I know it works the other way. isolinux's chain.c32 can load a grub stage
Comment by Gerhard Brauer (GerBra) - Wednesday, 19 August 2009, 09:16 GMT
Hmm, i have tried to let isolinux (chain)boot a grub loader, but without success. Don't remember what exactly failed. There are some hints when search about the topic, but the only i got running was the DOS version of grub...

The other direction, grub will start isolinux, will AFAIK not work in our situation. The reason for the grub prompt on these affected machines is IMHO that they could not load the menu.lst file. So no informations for grub to chainload an other bootloader....
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 19 August 2009, 12:44 GMT
In that case, wouldn't it be better to completely switch to either grub2 or isolinux?
Comment by Aaron Griffin (phrakture) - Friday, 04 September 2009, 21:31 GMT
I personally don't like isolinux. It feels a little crappy to me.

Grub2, I am unsure on the stability.

I really like grub, but it's a taste decision rather than a technical one.

Loading...