Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#11367 - pacman -Su not tracking deps (was: Xorg fail to start without libpciaccess)

Attached to Project: Pacman
Opened by Francesco Antonacci (punkeroso) - Monday, 01 September 2008, 13:00 GMT
Last edited by Allan McRae (Allan) - Tuesday, 02 September 2008, 23:59 GMT
Task Type Bug Report
Category Backend/Core
Status Closed
Assigned To Xavier (shining)
Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version 3.2.1
Due in Version 3.2.2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Xorg failed to start because libpciaccess is missing, so this should be added as xorg-server's dependency.

Additional info:

xorg-server 1.4.99.906-2

Steps to reproduce:
Just upgrade to xorg-server in testing.
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 02 September 2008, 23:59 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Monday, 01 September 2008, 13:12 GMT
Weird, it is listed as dependency in the PKGBUILD and on the website. It can't be missing.
Comment by Francesco Antonacci (punkeroso) - Monday, 01 September 2008, 13:42 GMT
Mhmh...it's true...but today, when I did pacman -Syu and restarted xorg, it didn't started and I had to manually install libpciaccess.
Here is my pacman.log:

[2008-09-01 14:32] starting full system upgrade
[2008-09-01 14:39] removed bluez-libs (3.32-1)
[2008-09-01 14:39] installed bluez (4.1-1)
[2008-09-01 14:39] upgraded binutils (2.18-8 -> 2.18-9)
[2008-09-01 14:39] upgraded file (4.25-1 -> 4.26-1)
[2008-09-01 14:39] upgraded gcc (4.3.1-3 -> 4.3.2-1)
[2008-09-01 14:39] upgraded gcc-libs (4.3.1-3 -> 4.3.2-1)
[2008-09-01 14:39] upgraded gdb (6.8-2 -> 6.8-3)
[2008-09-01 14:39] reloading init: done.
[2008-09-01 14:39] ==> ATTENTION INTERNATIONAL USERS:
[2008-09-01 14:39] ==>
[2008-09-01 14:39] ==> Locales are no longer included in the glibc package.
[2008-09-01 14:39] ==> They are generated by /usr/sbin/locale-gen depending on the contents
[2008-09-01 14:39] ==> of /etc/locale.gen.
[2008-09-01 14:39] ==> glibc will try to autodetect the required locales now, if you need
[2008-09-01 14:39] ==> additional locales, please enable them in /etc/locale.gen and run
[2008-09-01 14:39] ==> /usr/sbin/locale-gen
[2008-09-01 14:39] ==>
[2008-09-01 14:39] ==> Check /etc/locale.gen.pacnew for new supported locales
[2008-09-01 14:39] ==>
[2008-09-01 14:39] Generating locales...
[2008-09-01 14:39] en_US.UTF-8... done
[2008-09-01 14:39] en_US.ISO-8859-1... done
[2008-09-01 14:39] Generation complete.
[2008-09-01 14:39] upgraded glibc (2.8-2 -> 2.8-3)
[2008-09-01 14:39] upgraded inputproto (1.4.3-1 -> 1.4.4-1)
[2008-09-01 14:39] upgraded kernel-headers (2.6.25.8-1 -> 2.6.26.3-1)
[2008-09-01 14:39] upgraded libdrm (2.3.0-1 -> 2.3.1-1)
[2008-09-01 14:39] upgraded libxau (1.0.3-1 -> 1.0.4-1)
[2008-09-01 14:39] upgraded mesa (7.0.3-3 -> 7.1-1)
[2008-09-01 14:39] upgraded ncurses (5.6-7 -> 5.6-8)
[2008-09-01 14:39] upgraded ntfs-3g (1.2531-1 -> 1.2812-1)
[2008-09-01 14:39] Fixing gshadow file ...
[2008-09-01 14:39] 'punkeroso' is a member of the 'lp' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'video' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'audio' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'optical' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'floppy' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'storage' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'power' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'users' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'dbus' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'camera' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'scanner' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'hal' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] 'punkeroso' is a member of the 'games' group in /etc/group but not in /etc/gshadow
[2008-09-01 14:39] upgraded shadow (4.0.18.2-2 -> 4.1.2.1-2)
[2008-09-01 14:39] upgraded xf86-video-vesa (1.3.0-6 -> 2.0.0-2)
[2008-09-01 14:39] upgraded xorg-server (1.4.2-2 -> 1.4.99.906-2)
[2008-09-01 14:43] installed libpciaccess (0.10.3-1)

Regards
Comment by Jan de Groot (JGC) - Monday, 01 September 2008, 13:52 GMT
Very weird, the dependency is listed in testing.db.tar.gz, it's listed in the package and it's listed in the PKGBUILD... What does pacman -Qi libpciaccess show up in "Required by"?
This could be a pacman bug actually.
Comment by Francesco Antonacci (punkeroso) - Monday, 01 September 2008, 14:36 GMT
Name : libpciaccess
Version : 0.10.3-1
URL : http://xorg.freedesktop.org/
Licenses : custom
Groups : None
Provides : None
Depends On : glibc
Optional Deps : None
Required By : xorg-server
Conflicts With : None
Replaces : None
Installed Size : 108.00 K
Packager : Jan de Groot <jgc@archlinux.org>
Architecture : i686
Build Date : Sat 16 Aug 2008 11:09:10 PM CEST
Install Date : Mon 01 Sep 2008 02:43:16 PM CEST
Install Reason : Explicitly installed
Install Script : No
Description : X11 PCI access library


This is really weird!!!
Comment by Jan de Groot (JGC) - Monday, 01 September 2008, 17:42 GMT
I upgraded a box to the new xorg-server version today, and it installed libpciaccess when I asked it to install xorg-server. Your issue looks weird to me, but there's at least one developer that shares your experience.
Comment by Xavier (shining) - Tuesday, 02 September 2008, 12:22 GMT
This is bad.
Allan just pointed out a replace happened in both cases : bluez here, and synaptics in his case.
This will require some testing and investigation.
Comment by Dan McGee (toofishes) - Tuesday, 02 September 2008, 14:03 GMT
So this looks like a pacman bug, right? I'll move it to that project.
Comment by Allan McRae (Allan) - Tuesday, 02 September 2008, 14:21 GMT
Here is my log of the event:
[2008-09-01 10:03] starting full system upgrade
[2008-09-01 10:06]
[2008-09-01 10:06] ==> Don't forget to update your XF86Config or xorg.conf
[2008-09-01 10:06]
[2008-09-01 10:06] removed synaptics (0.14.6.99-2)
[2008-09-01 10:06] installed xf86-input-synaptics (0.15.0-1)
[2008-09-01 10:06] upgraded file (4.25-1 -> 4.26-1)
[2008-09-01 10:06] upgraded inputproto (1.4.3-1 -> 1.4.4-1)
[2008-09-01 10:06] upgraded intel-dri (7.0.3-1 -> 7.1-2)
[2008-09-01 10:06] upgraded libdrm (2.3.0-1 -> 2.3.1-1)
[2008-09-01 10:06] upgraded libgl (7.0.3-2 -> 7.1-2)
[2008-09-01 10:06] upgraded libxau (1.0.3-1 -> 1.0.4-1)
[2008-09-01 10:06] upgraded mesa (7.0.3-3 -> 7.1-1)
[2008-09-01 10:06] warning: /etc/default/useradd installed as /etc/default/useradd.pacnew
[2008-09-01 10:06] upgraded shadow (4.0.18.2-2 -> 4.1.2.1-2)
[2008-09-01 10:06] upgraded xf86-video-intel (2.3.2-1 -> 2.4.2-1)
[2008-09-01 10:06] upgraded xf86-video-vesa (1.3.0-6 -> 2.0.0-2)
[2008-09-01 10:06] upgraded xorg-server (1.4.2-2 -> 1.4.99.906-2)
[2008-09-01 10:12] installed libpciaccess (0.10.3-1)
Comment by Maciej Libuda (Mefju) - Tuesday, 02 September 2008, 14:44 GMT
I've upgraded to testing (without bluez and netcfg for now) and everything went smooth. Libpciaccess was installed and synaptics was replaced.
Comment by Xavier (shining) - Tuesday, 02 September 2008, 15:41 GMT
Sorry, it took me a while to realize it already happened before :
http://archlinux.org/pipermail/pacman-dev/2008-March/011491.html

Now I am just waiting for the confirmation that Allan and punkeroso did the same.

Edit : And if you did not specify the -d flag explicitly (for example : pacman -Sud), then we will have to figure out how it got enabled automatically.
Comment by Francesco Antonacci (punkeroso) - Tuesday, 02 September 2008, 17:03 GMT
Yes, I did a pacman -Sud because of bluez.
Comment by Xavier (shining) - Tuesday, 02 September 2008, 17:18 GMT
Well, -Sud was a bad idea.
A better way is to skip bluez upgrade until it is fixed.
IgnorePkg bluez in pacman.conf or --ignore bluez in cli.
Comment by Dan McGee (toofishes) - Tuesday, 02 September 2008, 17:25 GMT
  • Field changed: Summary (Xorg fail to start without libpciaccess → pacman -Su not tracking deps (was: Xorg fail to start without libpciaccess))
  • Field changed: Severity (High → Low)
How the hell can you expect pacman to install all dependencies *when you use the -d option*. You told it to *ignore* deps, and then you wonder why they are missing. I'm glad we were chasing a ghost here.
Comment by Allan McRae (Allan) - Tuesday, 02 September 2008, 23:59 GMT
I found a "pacman -Sud" im my bash history within the range of time this happened - although I remember this and am fairly sure this was for something else. Maybe I autocompleted to it by accident...

Loading...