Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11346 - postgresql PKGBUILD removes libpgport.a

Attached to Project: Arch Linux
Opened by Oveek Mallik (veek) - Saturday, 30 August 2008, 01:55 GMT
Last edited by Douglas Soares de Andrade (dsa) - Wednesday, 25 February 2009, 16:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Douglas Soares de Andrade (dsa)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The postgresql PKGBUILD manually removes the static library, libpgport.a,
with the following command:

rm -f $startdir/pkg/usr/lib/libpgport.a || return 1

Is there a reason for this? qt-copy-svn from AUR was looking for the library with
the -lpgport linker flag. I had to download the PKGBUILD, eliminate the above
line which removes libpgport.a, and rebuild postgresql. After installing, libpgport.a
was available in the lib directory, and qt-copy-svn built without error.

Additional info:
* package version(s)
pkgname=postgresql
pkgver=8.3.3
pkgrel=1
This task depends upon

Closed by  Douglas Soares de Andrade (dsa)
Wednesday, 25 February 2009, 16:08 GMT
Reason for closing:  Implemented
Comment by Pierre Schmitz (Pierre) - Sunday, 31 August 2008, 11:13 GMT
I am not sure if QT really needs that file. I have just rebuilt qt in [extra] with the follwing line added: sed -e '/pg_config --libs/d' -i configure

OT: You can use qt from [extra] instead qt-copy-svn from AUR. It should be almost the same because I applied the KDE patches, too.
Comment by Oveek Mallik (veek) - Tuesday, 02 September 2008, 13:13 GMT
Ah I'm sure you're right. I commented on this on the AUR page, but qt-copy-svn is absolutely massive when installed. It must have a ton of optional dependencies compiled in by default. I don't know what features are enabled by having libpgport compiled in, but I guess it's nothing crucial.

I'm still curious why it's removed from the postgresql package, but it's not a critical issue.
Comment by Luiz (netuno55) - Tuesday, 23 September 2008, 20:55 GMT
Qt4 needs that file to compile it's postgresql plugin driver, which qt applications that connect to PostgreSQL need. I had to recompile the PostgreSQL package removind the rm -f $startdir/pkg/usr/lib/libpgport.a || return 1 from the PKGBUILD file, and then compile qt ( I use qtmod but the issue is the same) to get the postgresql plugin.

Will the package maintainer please remove the line mentioned above from the PKGBUILD before generating this package. It is important for other apps.
Comment by Paul Mattal (paul) - Tuesday, 23 September 2008, 21:56 GMT
Does anyone know why that line is there in the first place? I am fairly sure I inherited it that way. If I can't find any reason for having it there, I'll plan to remove it.
Comment by Pierre Schmitz (Pierre) - Tuesday, 23 September 2008, 22:01 GMT
@Luiz: Please try QT from extra and not from kdemod. That should work. This .a file is not needed.
Comment by Luiz (netuno55) - Wednesday, 24 September 2008, 12:25 GMT
@Pierre I posted the issue to the kdemod patches forum. I suggested a patch, and they now seem to be using the same solution as the qt extra package. But I still don't know why this lib is being removed.
Comment by Paul Mattal (paul) - Wednesday, 24 September 2008, 18:19 GMT
Does it make sense to have these libraries in postgresql or postgresql-libs? Wouldn't it be libs?
Comment by Luiz (netuno55) - Wednesday, 24 September 2008, 18:29 GMT
I think it makes sense to have it on postgresql-libs, as it is a (static) lib.
Comment by Ryan Corder (rcorder) - Thursday, 13 November 2008, 19:48 GMT
I reported this problem as well because of a dependency for -lpgport when compiling Slony-I. Seems that bug was closed, probably because of being a duplicate. I hope this small change can be made soon; until then I'm compiling out of ABS with the change made to the PKGBUILD.
Comment by Ryan Corder (rcorder) - Thursday, 20 November 2008, 07:50 GMT
I've uploaded Slony-1 to AUR: http://aur.archlinux.org/packages.php?ID=21662

However, it will fail to build without this bug resolved. Until then, I'm suggesting that users that want to use Slony-1 to rebuild postgresql via ABS with the line in question in the PKGBUILD file commented out.

Loading...