Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.

FS#11333 - Local repository no longer works.

Attached to Project: Pacman
Opened by Emanuele Rampichini (lele85) - Thursday, 28 August 2008, 18:28 GMT
Last edited by Dan McGee (toofishes) - Thursday, 28 August 2008, 19:39 GMT
Task Type Bug Report
Category Scripts & Tools
Status Closed
Assigned To No-one
Architecture i686
Severity Medium
Priority Normal
Reported Version 3.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Summary and Info:

Pacman no longer works with my local repository. I think the problem is in file:/// protocol. I have moved my local repository behind apache and with http:// protocol it works.

Here the pacman error output:

file:///home/lele85/Packages/Repo/i686/prova.db.tar.gz: Unsupported scheme.
error: failed to update prova (unexpected error)

My working pacman.conf (HTTP):

Not working pacman.conf (FILE:///):

Steps to Reproduce:

Just build a local repository with repo-add.
This task depends upon

Closed by  Dan McGee (toofishes)
Thursday, 28 August 2008, 19:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Don't use XferCommand or use curl
Comment by Xavier (shining) - Thursday, 28 August 2008, 18:35 GMT
This is not a bug. wget does not support the file protocol. You can try curl instead.
But why do you use XferCommand at all?
Comment by Emanuele Rampichini (lele85) - Thursday, 28 August 2008, 18:43 GMT
I use XferCommand because sometimes i need to update my arch behind an http proxy.

I follow this how-to.

Maybe is not a bug but with the previous version of pacman everithing works well.
I'll try curl anyway and i'll let you know.
Comment by Xavier (shining) - Thursday, 28 August 2008, 18:48 GMT
This information is wrong.
You don't *need* XferCommand to use an http proxy.
Just comment out XferCommand, and keep your http_proxy environment variable, and everything should work.
Now I guess curl should work fine with proxy too, but don't use XferCommand unless you know what you are doing and you have a real reason for doing it.