Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11330 - klibc* depend on klibc-tQg242GqA9bO1EKgzWDvsh1E7nc

Attached to Project: Arch Linux
Opened by Andrea Scarpino (BaSh) - Thursday, 28 August 2008, 14:02 GMT
Last edited by Roman Kyrylych (Romashka) - Thursday, 28 August 2008, 19:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I re-built klibc and when I'm trying to install I get:

# pacman -U klibc-1.5-6-i686.pkg.tar.gz
loading package data...
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: klibc-extras: requires klibc-tQg242GqA9bO1EKgzWDvsh1E7nc
:: klibc-kbd: requires klibc-tQg242GqA9bO1EKgzWDvsh1E7nc
:: klibc-module-init-tools: requires klibc-tQg242GqA9bO1EKgzWDvsh1E7nc
:: klibc-udev: requires klibc-tQg242GqA9bO1EKgzWDvsh1E7nc

In fact:
pacman -Qi klibc-extras | grep Depends
Depends On : klibc klibc-tQg242GqA9bO1EKgzWDvsh1E7nc

pacman -Qi klibc-kbd | grep Depends
Depends On : klibc klibc-tQg242GqA9bO1EKgzWDvsh1E7nc kbd

pacman -Qi klibc-module-init-tools | grep Depends
Depends On : klibc klibc-tQg242GqA9bO1EKgzWDvsh1E7nc

pacman -Qi klibc-udev | grep Depends
Depends On : coreutils klibc klibc-tQg242GqA9bO1EKgzWDvsh1E7nc

Additional info:
* klibc-extras 2.4-2
* klibc-kbd 1.15.20080312-6
* klibc-udev 116-4
* klibc-module-init-tools 3.4-1

Steps to reproduce: cd /var/abs/core/klibc
makepkg
pacman -U klibc*.tar.gz
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Thursday, 28 August 2008, 19:56 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 28 August 2008, 14:30 GMT
This is because klibc uses some random string for its soname:
klibc /usr/lib/klibc/lib/klibc-yHIE3cyFqO2f4otZM2Oh8L9gexw.so

I guess your build changed the soname, so the provide calculated in the last line of the PKGBUILD is different. Installing your klibc package would break all the others depending on this, which is the reason for adding this weird versioned dependency.
Comment by Andrea Scarpino (BaSh) - Thursday, 28 August 2008, 14:33 GMT
Ok, I understand now
thanks, this bg can be closed

Loading...