Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11289 - unable to enumerate USB device

Attached to Project: Arch Linux
Opened by jonas enge (cybe-arch) - Friday, 22 August 2008, 18:55 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 08 February 2009, 16:04 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity Very Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I just bought a Holux GR-240 GPS. When i plugged the USB-charger in USB-port). dmesg shows this:
hub 1-0:1.0: unable to enumerate USB device on port 2
hub 1-0:1.0: unable to enumerate USB device on port 2
hub 1-0:1.0: unable to enumerate USB device on port 2
hub 1-0:1.0: unable to enumerate USB device on port 2
hub 1-0:1.0: unable to enumerate USB device on port 2
hub 1-0:1.0: unable to enumerate USB device on port 2
and on .. and on ... and on

Additional info:
* package version(s)
Kernel 2.6.26.2-1
* config and/or log files etc.


Steps to reproduce:
Put Holux GR-240 GPS' USB-charger in USB-port.
Closed by  Tobias Powalowski (tpowa)
Sunday, 08 February 2009, 16:04 GMT
Reason for closing:  Fixed
Comment by Glenn Matthys (RedShift) - Friday, 22 August 2008, 19:16 GMT
Please post a bugreport upstream @ http://bugzilla.kernel.org/. Make sure your device is not broken, test it under another OS to confirm it works properly.
Comment by Attila (attila) - Saturday, 23 August 2008, 07:28 GMT
After seeing the same messages as you for a internal device which is not connected i found out that this error messages be not helpfull in every situation and the important point is more "do your device works or not".

Here the infos what i found:
http://lkml.org/lkml/2008/4/26/217
http://kerneltrap.org/mailarchive/git-commits-head/2008/5/30/1978694
(if you understand german): http://www.debianforum.de/forum/viewtopic.php?f=33&p=638118
Comment by jonas enge (cybe-arch) - Saturday, 23 August 2008, 14:06 GMT
The device is not broken. In Ubuntu dmesg shows nothing when plugged in.
Comment by jonas enge (cybe-arch) - Saturday, 23 August 2008, 15:35 GMT
The device is not broken. In Ubuntu dmesg shows nothing when plugged in.
Comment by Attila (attila) - Saturday, 23 August 2008, 15:56 GMT
Than perhaps the Ubuntu kernel is patched because the little what i understand is that instead of elder kernel versions this message can comes earlier as before and is not even bad. Not nice but on the other hand an information is better than no information. -)
Comment by Tobias Powalowski (tpowa) - Friday, 14 November 2008, 08:32 GMT
you could try to load your usb hostcontrollers in this order in rc.conf or mkinitcpio.conf:
MODULES=(ehci-hcd uhci-hcd)
Comment by jonas enge (cybe-arch) - Friday, 14 November 2008, 14:17 GMT
Thanks, I'll try that.
Comment by Tobias Powalowski (tpowa) - Friday, 28 November 2008, 09:18 GMT
status on this?
Comment by Attila (attila) - Saturday, 29 November 2008, 07:22 GMT
In my case this messages gone away since i use kernel 2.6.27.7 (own kernel package) and so perhpas jonas could recognize the same if kernel26 steps to the same version.
Comment by Denis A. Altoe Falqueto (denisfalqueto) - Thursday, 04 December 2008, 15:28 GMT
I confirm that loading ehci-hcd before uhci-hcd solves the problem. I have a midi to usb cable and on Ubuntu (kernel 2,6,24) it worked but not on Arch (kernel 2,6,27). In another Arch box with an old kernel (can't check right now) the cable worked fine without any special configuration. Great to know that there is a workaround.

Loading...