Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11242 - need mysql-5.0.60 more dependency ?

Attached to Project: Arch Linux
Opened by Alois Nespor (anespor) - Sunday, 17 August 2008, 19:09 GMT
Last edited by Douglas Soares de Andrade (dsa) - Sunday, 11 January 2009, 12:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Alexander Baldeck (kth5)
Douglas Soares de Andrade (dsa)
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date 2009-01-05
Percent Complete 100%
Votes 0
Private No

Details

Description:

mysql contains a command mysqlhotcopy, that it requires an additional 2 packages from [extra] - perl-dbi and perl-dbd-mysql, which is not installed along with mysql.

Steps to reproduce:

bash-3.2# mysqlhotcopy /home/WWW/zaloha/mysql/

Can't locate DBI.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.10.0 /usr/share/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl /usr/lib/perl5/current /usr/lib/perl5/site_perl/current .) at /usr/bin/mysqlhotcopy line 8.
BEGIN failed--compilation aborted at /usr/bin/mysqlhotcopy line 8.

bash-3.2# pacman -S perl-dbi
řeším závislosti...
kontroluji interní konflikty...

Cíle (1): perl-dbi-1.601-1

Celková velikost stahování: 0,70 MB
Celková velikost instalace: 1,73 MB

Pokračovat v instalaci? [A/n]
:: Získávám balíčky z extra...
perl-dbi-1.601-1-x86_64 719,9K 224,1K/s 00:00:03 [#####################] 100%
kontroluji integritu balíčků...
(1/1) kontroluji konflikty mezi soubory [#####################] 100%
(1/1) instaluji perl-dbi [#####################] 100%

bash-3.2# mysqlhotcopy /home/WWW/zaloha/mysql/
install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.10.0 /usr/share/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl /usr/lib/perl5/current /usr/lib/perl5/site_perl/current .) at (eval 8) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: DBM, ExampleP, File, Gofer, Proxy, Sponge.
at /usr/bin/mysqlhotcopy line 177

bash-3.2# pacman -S perl-dbd-mysql
řeším závislosti...
kontroluji interní konflikty...

Cíle (1): perl-dbd-mysql-4.006-1

Celková velikost stahování: 0,11 MB
Celková velikost instalace: 0,30 MB

Pokračovat v instalaci? [A/n]
:: Získávám balíčky z extra...
perl-dbd-mysql-4.00... 110,0K 226,3K/s 00:00:00 [#####################] 100%
kontroluji integritu balíčků...
(1/1) kontroluji konflikty mezi soubory [#####################] 100%
(1/1) instaluji perl-dbd-mysql [#####################] 100%


--> mysqlhotcopy now works correctly
This task depends upon

Closed by  Douglas Soares de Andrade (dsa)
Sunday, 11 January 2009, 12:23 GMT
Reason for closing:  Implemented
Comment by Alois Nespor (anespor) - Sunday, 17 August 2008, 19:12 GMT
sorry this bug is for Arch linux section (extra), not for community packages
Comment by Glenn Matthys (RedShift) - Friday, 05 December 2008, 14:37 GMT
These dependencies should be added as optdepends.

Loading...