AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#11187 - Can't update package - can't create directory /home/aur/unsupported/<pkgname>

Attached to Project: AUR web interface
Opened by Vitaliy Berdinskikh (skipper13) - Monday, 11 August 2008, 18:04 GMT
Last edited by Callan Barrett (wizzomafizzo) - Sunday, 28 September 2008, 15:36 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To Loui Chang (louipc)
Architecture All
Severity Medium
Priority High
Reported Version 1.5.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

I can't update jedit-devel.

A few days ago same problem with tomcat6

Please add your list of bad directories here for now.
http://wiki.archlinux.org/index.php/AUR_CleanUp_Day

Thanks.
   aur.png (80.3 KiB)
This task depends upon

Closed by  Callan Barrett (wizzomafizzo)
Sunday, 28 September 2008, 15:36 GMT
Reason for closing:  Fixed
Comment by Henning Garus (garns) - Tuesday, 12 August 2008, 13:34 GMT
I've got the same problem with bash_completion_lib.

After trying to submit an update the directory is empty and I get the error message: Could not create directory /home/aur/unsupported/bash_completion_lib

Could this result from uploading a pkg without an updated $pkgrel / $pkgversion ?
Comment by Vitaliy Berdinskikh (skipper13) - Tuesday, 12 August 2008, 18:44 GMT
I found bug. It's a makepkg.

"makepkg --source" makes tarbol with PKGBUILD and soft links instrad of files.
Comment by Henning Garus (garns) - Tuesday, 12 August 2008, 19:12 GMT
the bug in makepkg has already been fixed in git.

But I think, AUR shouldn't behave like this when a tar containing a soft link is uploaded.
Comment by Vitaliy Berdinskikh (skipper13) - Saturday, 23 August 2008, 12:25 GMT
From: Vitaliy Berdinskikh <***@root.ua>
To: aur-general@archlinux.org
Subject: Re: [aur-general] Remove bad packages
Date: Sat, 23 Aug 2008 14:29:10 +0300
X-Mailer: Claws Mail 3.5.0 (GTK+ 2.12.11; i686-pc-linux-gnu)

В Sat, 23 Aug 2008 11:58:46 +0200
"Andrea Scarpino" <***@gmail.com> пишет:

> 2008/8/23 Vitaliy Berdinskikh <***@root.ua>:
> > Who can remove two of my packages on AUR: tomcat6 and jedit-devel?
> >
> > These packages are broke. I can't update them. So remove them,
> > please - I will upload.
> Done, try now
Thanks Andrea!


But I still can't update
AUR says "Could not create directory /home/aur/unsupported/tomcat6."
and "Could not create directory /home/aur/unsupported/jedit-devel."

I's seen AUR sources and found that at web/html/pkgsubmit.php
http://pastie.org/258530

I guess AUR can't make dir:

"
if (!@mkdir(INCOMING_DIR . $pkg_name)) {
$error = __( "Could not create directory %s.", INCOMING_DIR . $pkg_name); }
"

Why? I have no idea.

My packages are
http://skipper13.root.ua/packages/jedit-devel-4.3pre15-2.src.tar.gz
http://skipper13.root.ua/packages/tomcat6-6.0.18-3.src.tar.gz
Comment by Vitaliy Berdinskikh (skipper13) - Saturday, 23 August 2008, 15:52 GMT Comment by Loui Chang (louipc) - Saturday, 23 August 2008, 21:33 GMT
Well, I can reproduce it.

Hmm something is really screwy here. It seems like there's some issue
with PHP. Those tarballs with symlinks seem to trigger some
"open_basedir restriction". After that restriction is triggered it
doesn't matter if subsequent tarballs are good.

At the same time there seems to be some kind of flaw where directories in
unsupported-temp are not being deleted. So that directory will probably
be filled with garbage on the server.

I shall investigate further.
Comment by Loui Chang (louipc) - Saturday, 23 August 2008, 21:41 GMT
Also it seems that removing the offending directories does remove
the restriction.
Comment by Vitaliy Berdinskikh (skipper13) - Saturday, 23 August 2008, 21:56 GMT
Loui thanks for your work.

You are the true hacker :)
Comment by Loui Chang (louipc) - Sunday, 14 September 2008, 15:39 GMT
It seems that PHP doesn't handle symlinks very well. Self-referencing
symlinks just put PHP into some kind of loop and it gives up on them
after awhile. I've written a patch [1] that uses the system 'rm' to clean up
the package's directory so that those self-referencing symlinks don't
cause a snag.

[1] http://archlinux.org/pipermail/aur-dev/2008-September/000450.html

Loading...