Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11177 - Catalyst 8.7-1.1 (fglrx) + new kernel26 2.6.26.2-1

Attached to Project: Arch Linux
Opened by Cristian C. (ckristi) - Monday, 11 August 2008, 05:56 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 11 August 2008, 18:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Catalyst driver cannot initialize Direct Rendering.
I own an ATI Mobility X2300 and since the latest update it fails to provide 3D acceleration.

Additional info:
* catalyst 8.7-1.1 / kernel26-2.6.26.2-1
* This is what I found after a little research (dmesg, because Xorg.0.log didn't seem relevant):
[fglrx] Reserved FB block: Shared offset:0, size:1000000
[fglrx] Reserved FB block: Unshared offset:7fbb000, size:40000
[fglrx] Reserved FB block: Unshared offset:7ffb000, size:5000
[fglrx:__create_mapping] *ERROR* Could not find the group private data
[fglrx:__mc_heap_map_virtual_space] *ERROR* Failed to map the virtual space
[fglrx:mc_heap_map_virtual_space] *ERROR* Can not get virtual address
[fglrx:MCIL_GetVirtualAddressInDescriptor] *ERROR* Can not get the virtual address



Steps to reproduce:
Well... load fglrx and start X. :)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 11 August 2008, 18:24 GMT
Reason for closing:  Fixed
Comment by Cristian C. (ckristi) - Monday, 11 August 2008, 06:01 GMT
For more information there's a forum thread open for this issue, here: http://bbs.archlinux.org/viewtopic.php?id=53217
Comment by Greg (dolby) - Monday, 11 August 2008, 17:22 GMT
Does Catalyst 8.7-2 solve this?
Comment by Cristian C. (ckristi) - Monday, 11 August 2008, 18:23 GMT
Yes, it does. Just tested it. I'll request closure. :)

Loading...