Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11098 - qtcurve broken

Attached to Project: Arch Linux
Opened by Nicola (drakkan) - Sunday, 03 August 2008, 06:11 GMT
Last edited by Pierre Schmitz (Pierre) - Sunday, 14 September 2008, 13:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture i686
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

after update to the last qtcurve-(gtk2,kde3,kde4) qtconfig doesn't show qtcurve anymore, both /opt/qt/bin/qtconfig (qt3) and /usr/bin/qtconfig (qt4) I'm using kde4 from extra no kdemod,

Additional info:
* package version(s)
* config and/or log files etc.

pacman -Qs qtcurve
local/qtcurve-gtk2 0.59.7-1 (qtcurve)
A configurable set of widget styles for KDE and Gtk
local/qtcurve-kde3 0.59.5-1 (qtcurve)
A configurable set of widget styles for KDE and Gtk
local/qtcurve-kde4 0.59.6-1 (qtcurve)
A configurable set of widget styles for KDE and Gtk


Steps to reproduce:

install the latest qtcurve run opt/qt/bin/qtconfig and then /usr/bin/qtconfig, in both case in "gui style" you should be able to choose qtcurve but this doesn't show up
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Sunday, 14 September 2008, 13:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  qtcurve-kde4 is fixed. However: I don't know any way to add the lib path to qt3 systemwide
Comment by Nicolas Doualot (slubman) - Sunday, 03 August 2008, 09:06 GMT
Same problem here.

Recompile packagess solve the issue here.
Comment by Nicola (drakkan) - Sunday, 03 August 2008, 09:43 GMT
rebuild solve the issue only for qtcurve-kde4,

qtcurve-kde3 is still broken:

/opt/qt/bin/qtconfig give no option to select qtcurve
Comment by Dincer Celik (roadboy) - Wednesday, 06 August 2008, 09:43 GMT
Same problem with qtcurve-kde4 and kdemod after upgrading from 0.59.6-2 to 0.59.6-3. Downgrading back to 0.59.6-2 fixes problem.
Comment by Pierre Schmitz (Pierre) - Wednesday, 06 August 2008, 10:00 GMT
Does this problem still exist? At least qtcurve-kde4 should be fixed; I don't know how to fix qtconfig of qt3.
Comment by Nicola (drakkan) - Wednesday, 06 August 2008, 10:12 GMT
I can confirm qtcurve-kde4 from repo works fine now.

qtcurve-qt3 is still broken
Comment by Nicola (drakkan) - Wednesday, 06 August 2008, 10:57 GMT
for qtcurve-kde3 if you link kstyle_qtcurve_config.la and kstyle_qtcurve_config.so in /opt/qt/lib and then qtcurve.so in /opt/qt/plugins/styles qtcurve appears in qtconfig and works for apps such as hplip (pure ), however kde3 apps such as kaffeine doesn't show the correct style and we haven't kcontrol for kde3 anymore ...
Comment by Pierre Schmitz (Pierre) - Wednesday, 06 August 2008, 12:08 GMT
Setting the following in ~/.qt/qtrc solves the problem:

[3.3]
libraryPath=/opt/kde/lib/kde3/plugins:/opt/qt/plugins:/opt/qt/bin

If anybody knows how to set this system-wide, plese let me know. QT-4 reads an env like QT_PLUGINPATH, QT-3 does not.
Comment by Nicola (drakkan) - Wednesday, 06 August 2008, 12:45 GMT
thanks Pierre however this way apps like hplip works fine but other like kaffeine remain with the default theme
Comment by Dincer Celik (roadboy) - Wednesday, 06 August 2008, 19:22 GMT
qtcurve-kde4 problem got fixed after the latest kdemod updates.

Loading...