Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11039 - transcode isn't properly linked against ImageMagick

Attached to Project: Arch Linux
Opened by Cyriac BENOIT (cycyx) - Tuesday, 29 July 2008, 01:03 GMT
Last edited by Eric Belanger (Snowman) - Monday, 19 January 2009, 06:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Eric Belanger (Snowman)
Architecture i686
Severity Low
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: can't use "im" import or export filter in transcode, becaude there is no /usr/lib/transcode/{export,import}_im.so.
When compiled using the given PKGBUILD, transcode is linked against libMagick.so instead of libMagickCore.so, thus the configure script cannot find the InitMagick function in library.


Additional info:
* extra/transcode 1.0.6rc1-2

Steps to reproduce:
* try using the "-y im" option or making a shaped menu with tovid (aur).

When compiling, the configure script also warn about not being able to link against libpostproc...
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 19 January 2009, 06:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in transcode 1.1.0-1 in extra
Comment by Tobias Kieslich (tobias) - Thursday, 16 October 2008, 21:56 GMT
that's upstream as it looks for libMagick
but imagemagick has libMagickCore and libMagic++ now so it failes
That can't be fixed in the package, since it's very likely the API
Comment by Glenn Matthys (RedShift) - Friday, 12 December 2008, 20:42 GMT
What's the status of this issue?
Comment by Eric Belanger (Snowman) - Tuesday, 06 January 2009, 06:40 GMT Comment by Eric Belanger (Snowman) - Saturday, 10 January 2009, 22:02 GMT
I'm working on an ffmpeg/x264 update. For the rebuild, I'll update transcode and fix this bug.
Comment by Tobias Kieslich (tobias) - Saturday, 10 January 2009, 22:51 GMT
transcoding 1.07 is available, the issue should be fixed in that.
Comment by Eric Belanger (Snowman) - Saturday, 10 January 2009, 23:41 GMT
It's not fixed in transcode 1.0.7. Probably they are using an older version of imagemagick.

Loading...