Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11033 - Xmoto crashes after ode upgrade

Attached to Project: Arch Linux
Opened by Nelson Menon (nelsonmenon) - Monday, 28 July 2008, 20:06 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 30 July 2008, 11:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture i686
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After ode upgrade xmoto crashes at game starts.

Additional info:
* package version(s)
extra/xmoto 0.4.2-1
extra/ode 0.10.0-3

* config and/or log files etc.
ODE INTERNAL ERROR 1: assertion "g_bODEInitialized" failed in dCloseODE() [odeinit.cpp]
Aborted

Steps to reproduce:
upgrade ode
run xmoto
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 30 July 2008, 11:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 0.4.2-2
Comment by Ronald van Haren (pressh) - Monday, 28 July 2008, 23:41 GMT
it's an upstream bug. I'll see if I can find a patch somewhere. If you have one yourself, feel free to submit it to me :)
Comment by Nelson Menon (nelsonmenon) - Monday, 28 July 2008, 23:51 GMT
i dont have any patch
Comment by Clément LEGER (Wiz) - Tuesday, 29 July 2008, 17:17 GMT
Still do not know if it's a xmoto's problem or a ode problem : ODE documentation tells dInitODE is a useless function, but since ode 0.10 it makes xmoto crash (others applications ?).
The only way to make xmoto works here, is to add a call to this function.

Here is a patch that will do the trick, until the one with the wrong code does corrects it.
Thanks to aspegic500 for this ( http://forum.xmoto.tuxfamily.org/viewtopic.php?t=353 ), all my attemps to fix the bug as failed since I was trusting ODE's doc.
Comment by Ronald van Haren (pressh) - Tuesday, 29 July 2008, 21:43 GMT
thanks for the patch. I'll get to it tomorrow.
Comment by Nelson Menon (nelsonmenon) - Wednesday, 30 July 2008, 00:47 GMT
how can i do this patch to make xmoto work here ?

Loading...