Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11015 - Apply the upstream patches to the ncurses package

Attached to Project: Arch Linux
Opened by Greg (dolby) - Sunday, 27 July 2008, 10:12 GMT
Last edited by Allan McRae (Allan) - Friday, 22 August 2008, 02:44 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity High
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Latest ncurses version was released in late 2006. Since then the application has been updating with frequent patches. eg Like bash or vim gets updated. A summary of the patches can be found on http://invisible-island.net/ncurses/NEWS.gz while the patches themselves on ftp://invisible-island.net/ncurses/5.6/ .
I am not 100% sure but i think that the lack of those patches might be one of the reasons our ncurses dont operate 100% well. Or it seems like it.
Additional info can be found at http://invisible-island.net/ncurses/ncurses.faq.html
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 22 August 2008, 02:44 GMT
Reason for closing:  Won't implement
Additional comments about closing:  See final comment
Comment by Allan McRae (Allan) - Sunday, 27 July 2008, 11:24 GMT
As far as I can tell, the patches are mostly to get to the latest developmental version.

I will apply the coverity patch.
Comment by Greg (dolby) - Sunday, 27 July 2008, 11:38 GMT
Well in order to compile with gcc 4.3.1 it seems theres at least the latest patch needed also. IMO you cant really call the patches a devel version. Like i wrote before ncurses seems to update like vim and bash. We apply those patches cause stable releases have long development cycles. IMO we should apply all those patches.
Comment by Allan McRae (Allan) - Friday, 22 August 2008, 02:44 GMT
These are developmental patches so I won't apply them. The new ncurses package with only wide charater support should fix many problems.

Loading...