Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11006 - GCC crashes with SEGFAULT

Attached to Project: Arch Linux
Opened by Lukas Kropatschek (lukrop) - Friday, 25 July 2008, 11:43 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 25 July 2008, 19:49 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Whenever I compile a bigger package (e.g. kdebase or amarok2) gcc (4.3.1-2) crashes with a Segmentation fault. Everything works fine with gcc 4.3.1-1.

Additional info:

problem occurs with gcc 4.3.1-2
everything works with 4.3.1-1

[ 91%] Building CXX object src/servicebrowser/lastfm/CMakeFiles/amarok_service_lastfm.dir/libUnicorn/TrackInfo.o
In file included from /home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.cpp:23:
/home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.h:92: warning: type qualifiers ignored on function return type
/home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.h:95: warning: type qualifiers ignored on function return type
/home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.h:98: warning: type qualifiers ignored on function return type
/home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.h:123: warning: type qualifiers ignored on function return type
/home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.cpp: In constructor ‘TrackInfo::TrackInfo(const QDomElement&)’:
/home/lukrop/tmp/amarok2/src/amarok-1.86/src/servicebrowser/lastfm/libUnicorn/TrackInfo.cpp:87: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make[2]: *** [src/servicebrowser/lastfm/CMakeFiles/amarok_service_lastfm.dir/libUnicorn/TrackInfo.o] Error1
make[1]: *** [src/servicebrowser/lastfm/CMakeFiles/amarok_service_lastfm.dir/all] Error 2
make: *** [all] Error 2


Steps to reproduce:
Compile a "large" number of object files, e.g. kdebase or amarok2.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 25 July 2008, 19:49 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Friday, 25 July 2008, 17:37 GMT
new gcc snapshot just uploading to testing. please report if it solves your problems.
Comment by Lukas Kropatschek (lukrop) - Friday, 25 July 2008, 18:26 GMT
sorry but i don't find, maybe because my mirror isn't up to date but i don't find it in the ABS too. Is it my fault?
Comment by Lukas Kropatschek (lukrop) - Friday, 25 July 2008, 18:39 GMT
ok, got it from the ftp server.

Seems like it's fixed! :)

I'm going to test a little bit more but it completed amarok2 without problems (with the gcc-4.3.1-2 it crashed something around 5 times until the amarok2 build was finished).

I'm happy ;)

Loading...