Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#11004 - Sonata cannot edit tags anymore

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Friday, 25 July 2008, 09:22 GMT
Last edited by Greg (dolby) - Saturday, 26 July 2008, 18:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To James Rayner (iphitus)
Architecture i686
Severity Medium
Priority Normal
Reported Version None
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
I can't edit tags with Sonata anymore, even though tagpy and libtag are installed.


Package version:
Sonata 1.5.2


Console output:

$ sonata
Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/sonata/main.py", line 6713, in on_tags_edit
ui.show_msg(self.window, _("Taglib and/or tagpy not found, tag editing support disabled."), _("Edit Tags"), 'editTagsError', gtk.BUTTONS_CLOSE, self.dialog_destroy)
File "/usr/lib/python2.5/site-packages/sonata/ui.py", line 193, in show_msg
dialog.set_default_response(default)
TypeError: an integer is required
This task depends upon

Closed by  Greg (dolby)
Saturday, 26 July 2008, 18:58 GMT
Reason for closing:  Not a bug
Comment by Smith Dhumbumroong (zodmaner) - Friday, 25 July 2008, 12:36 GMT
This bug also affects x86_64.

Sonata output the same error message to console as above.





Comment by Angel Velasquez (angvp) - Saturday, 26 July 2008, 13:15 GMT
tagpy is the library for tag editing funtionality, in order to edit tags you have to install it.

This bug can be closed :)
Comment by Greg (dolby) - Saturday, 26 July 2008, 13:19 GMT
Maybe you missed the description part
"Description:
I can't edit tags with Sonata anymore, even though tagpy and libtag are installed."
Comment by Angel Velasquez (angvp) - Saturday, 26 July 2008, 13:30 GMT
No, i'm *editing tags with sonata just right now*

ui.show_msg(self.window, _("Taglib and/or tagpy not found, tag editing support disabled."), _("Edit Tags"), 'editTagsError', gtk.BUTTONS_CLOSE, self.dialog_destroy)

Should check if the packages are *good installed* i am using tagpy; Please be sure that /usr/lib/python2.5/site-packages/tagpy/ dir isn't empty
Comment by Smith Dhumbumroong (zodmaner) - Saturday, 26 July 2008, 14:18 GMT
Let me clarify. I *already* have tagpy installed (same as the original submitter) and I can confirm that tag editing is *still* broken here on my system.

I can also confirm that it used to work on my system. Alas, I cannot tell how or when it is broke, since I don't edit tag that much, but it isn't working right now.

I'm using:
-sonata 1.5.2-1
-tagpy 0.94.5-1

What version of Sonata and tagpy are you using, angvp?
Comment by Smith Dhumbumroong (zodmaner) - Saturday, 26 July 2008, 14:22 GMT
Also, I've checked, and my /usr/lib/python2.5/site-packages/tagpy folder isn't empty:

smith ~ $ ls /usr/lib/python2.5/site-packages/tagpy/
__init__.py ape.py flac.py id3v1.py id3v2.py mpc.py mpeg.py ogg
__init__.pyc ape.pyc flac.pyc id3v1.pyc id3v2.pyc mpc.pyc mpeg.pyc


Comment by Angel Velasquez (angvp) - Saturday, 26 July 2008, 17:50 GMT
Could you do this:

python -c "import tagpy"

You should see the following, by example:

[angvp@andr3a ~ ]$ python -c "import tagpy"
[angvp@andr3a ~ ]$

I am using:

- sonata 1.5.2-1
- tagpy 0.94.5-1
- python 2.5.2-5

Besides i have these packages too:

extra/tunepimp 0.5.3-5 [installed]
extra/taglib 1.5-1 [installed]
extra/libid3tag 0.15.1b-2 [installed]
community/tagpy 0.94.5-1 [installed]

I got working sonata tag editor on i686 and x86_64
Comment by Smith Dhumbumroong (zodmaner) - Saturday, 26 July 2008, 18:11 GMT
Issuing python -c "import tagpy" produces this:

smith ~ $ python -c "import tagpy"
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/usr/lib/python2.5/site-packages/tagpy/__init__.py", line 24, in <module>
import _tagpy
ImportError: /usr/lib/python2.5/site-packages/_tagpy.so: undefined symbol: _ZN5boost6python9converter8registry9push_backEPFPvP7_objectEPFvS5_PNS1_30rvalue_from_python_stage1_dataEENS0_9type_infoE

I also got the following packages installed too, in addition to tagpy:
- taglib 1.5-1
- libid3tag 0.15.1b-2

Install tunepimp didn't seems to solve the problem, unfortunately.
Comment by Smith Dhumbumroong (zodmaner) - Saturday, 26 July 2008, 18:33 GMT
OK, I finally fix this problem by recompile tagpy using ABS. :)

So, it appears tagpy need to be recompile to fix this problem, should I file a new bug report?

Comment by Greg (dolby) - Saturday, 26 July 2008, 18:58 GMT
Yes but make sure to do that in the community section of the bug tracker ;)

Loading...