Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10949 - [spidermonkey] missing header

Attached to Project: Arch Linux
Opened by Ray Rashif (schivmeister) - Friday, 18 July 2008, 13:27 GMT
Last edited by Hugo Doria (hdoria) - Wednesday, 03 June 2009, 14:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Douglas Soares de Andrade (dsa)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Issue:

jsutil.h

Reason:

Required by some software/third-party packages that depend on this one. However, spidermonkey-1.7 doesn't provide it. Looking at the rest in /usr/include/js, 4 of them appear to source/include this one.

Bug is evidently upstream, but it should be included with the package as other files are referencing it. Simple case of adding the file in concern to the Makefile.ref; see patch attached.

Example scenario:

google-gadgets - http://aur.archlinux.org/packages.php?ID=17378
This task depends upon

Closed by  Hugo Doria (hdoria)
Wednesday, 03 June 2009, 14:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  provided by xulrunner as devel/unstable header.
Comment by Glenn Matthys (RedShift) - Friday, 18 July 2008, 15:15 GMT
You said yourself it's an upstream issue, did you post a bugreport upstream?
Comment by Ray Rashif (schivmeister) - Friday, 18 July 2008, 17:17 GMT
Like mentioned, the reason why this should be a valid bug downstream, albeit low-priority, is because there are files referencing the header:

/usr/include/js $ grep jsutil.h *

jsbit.h:#include "jsutil.h"
jscntxt.h:#include "jsutil.h"
jsgc.h:#include "jsutil.h"
jsopcode.h:#include "jsutil.h"

http://bugs.gentoo.org/show_bug.cgi?id=28175

https://bugzilla.mozilla.org/show_bug.cgi?id=401300

We can take a firm stand with patching and stuff but this is an exception solely because it is just a missing package file - because the export didn't include it. Now if nobody agrees then it's fine but dolby, I would've expected you to at least grant me a reply before closing it (:
Comment by Greg (dolby) - Friday, 18 July 2008, 17:22 GMT
You could have posted the link from mozilla when you made the bug report.
Comment by Ray Rashif (schivmeister) - Friday, 18 July 2008, 17:28 GMT
Yes, my mistake for thinking the file-based justification to be enough, sorry =/
Comment by Jonatan A. Bravo (zephrax) - Saturday, 16 August 2008, 01:04 GMT
I solved this problem copying the header from thunderbird includes... I made this:

(In /usr/include/js)
# cp ../thunderbird-2.0.0.16/js/jsutil.h ./

After that, I can compile successfully google gadgets from source

Comment by Ray Rashif (schivmeister) - Saturday, 16 August 2008, 08:37 GMT
It can be solved in a multitude of ways (and AUR/unsupported packages should be left out of the discussion if possible). The problem is, trivially, whether it's supposed to be provided by spidermonkey or some other package in extra/community (that is why the bug is here, otherwise it's upstream or invalid).

From the AUR page of google-gadgets:

"BTW, spidermonkey in our repo is way out of date, and is already included by the latest xulrunner."

And:

"According to the author James Su, it's a bug of xulrunner. He asked to report it to our devs..."

--- Note to bughunters: This can be safely closed if the header is indeed the one provided by xulrunner instead of spidermonkey (reason for closure would be "incorrect affected package" or simply "not a bug"), thank you. ---

Loading...