Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10769 - Crafty unable to use multiple cores on SMP machines

Attached to Project: Community Packages
Opened by Christos Gitsis (vega) - Friday, 27 June 2008, 14:29 GMT
Last edited by Allan McRae (Allan) - Monday, 07 July 2008, 09:14 GMT
Task Type Feature Request
Category
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The version of Crafty (chess playing program) available in pacman can only use one CPU even if it is installed on an SMP machine.
Since SMP machines are now becoming widely available, I would suggest that crafty be compiled with the option -DCPUS=4 in the future, so that it can use up to 4 cores. This would not affect single-CPU systems, but it would benefit owners of quad systems, since crafty could search up to 4 times faster and thus play chess at a higher level.


Additional info:
* package version(s) Crafty v22.1

Steps to reproduce:

$>crafty

[...]
Crafty v22.1 (1 cpus)

White(1): smpmt 4
ERROR - Crafty was compiled with CPUS=1. mt can not exceed this value.
max threads set to 1

This task depends upon

Closed by  Allan McRae (Allan)
Monday, 07 July 2008, 09:14 GMT
Reason for closing:  Fixed
Comment by Allan McRae (Allan) - Monday, 07 July 2008, 09:14 GMT
I went to 8 CPUs. I figure that dual quad-cores are not that uncommon now.

Loading...