Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10740 - [openoffice-base] Application hangs when opening printer dialog

Attached to Project: Arch Linux
Opened by Gerhard Brauer (GerBra) - Monday, 23 June 2008, 14:01 GMT
Last edited by Greg (dolby) - Wednesday, 09 July 2008, 15:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Trying to print something from any ooo app got this application to hang.
There is also a thread on bbs: http://bbs.archlinux.org/viewtopic.php?id=50439
Seems to a problem on both architectures, we have also a report on archlinux.de

I've figured out that this is only applies when env var OOO_FORCE_DESKTOP is NOT set. So a temporary solution is to set OOO_FORCE_DESKTOP either to kde or gnome.


Additional info:
* package version(s)
openoffice-base 2.4.1-1
* config and/or log files etc.
[gerhard@tux1 ~]$ soffice
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_v
alue != 0' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
`G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
`G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
`G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_v
alue != 0' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
`G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(process:5556): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_v
alue != 0' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
`G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(process:5556): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_v
alue != 0' failed
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: gtype.c:2248: initialization assertion
failed, use IA__g_type_init() prior to this function
(process:5556): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
`G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(process:5556): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_v
alue != 0' failed
(process:5556): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJ
ECT (object_type)' failed

Steps to reproduce:
unset OOO_FORCE_DESKTOP
soffice (try a new doc, try to print it)

export OOO_FORCE_DESKTOP=kde
Printing is ok
export OOO_FORCE_DESKTOP=gnome
Printing is ok
This task depends upon

Closed by  Greg (dolby)
Wednesday, 09 July 2008, 15:31 GMT
Reason for closing:  Fixed
Comment by Gerhard Brauer (GerBra) - Monday, 23 June 2008, 16:36 GMT
Additional info:
it seems that there is no problem when using a KDE Desktop, regardless if above ENV-var is set or not.
(Verfified by one user, on Gnome i don't know)

Here i have the problem on openbox and we have a positive failure also on fluxbox.
Comment by Jan de Groot (JGC) - Monday, 23 June 2008, 17:44 GMT
Hmm, I thought we forced the GTK VCL plugin in openoffice 2.4, but somehow this got removed because people think GTK is ugly.
The problem is that OpenOffice tries to detect a GTK environment and starts using GTK features even when GTK isn't initialized, resulting in critical assertions and hanging applications.
Comment by Andreas Radke (AndyRTR) - Tuesday, 08 July 2008, 15:59 GMT
please check 2.4.1-2 in testing (x86_64 right now, i686 will soon follow)
Comment by Gerhard Brauer (GerBra) - Wednesday, 09 July 2008, 15:11 GMT
Tested 2.4.1-2 from testing (must also install cups/ghostscript from testing). Bug seems to be solved. Tested from openbox with/without OOO_FORCE_DESKTOP and from KDE.

Loading...