Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10689 - Build mutt against ncurses instead of slang.

Attached to Project: Arch Linux
Opened by Loui Chang (louipc) - Wednesday, 18 June 2008, 20:37 GMT
Last edited by Greg (dolby) - Thursday, 19 June 2008, 12:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I'm not sure whether to put this in a feature request or a bug report,
but I'll stick it to a bug report. Hopefully it'll get more attention.

Here's a few reasons:
* Building mutt against slang seems to cause some quirks with background
and highlighting. (At least for me)
* Ncurses is in core so there's a greater chance people already have it
installed.
* Ncurses seems to be the default build configuration.

I've attached two images of what mutt looks like with slang and with ncurses.
Notice how the highlighting is all broken up by whitespace with slang whereas
highlighting is continuous with ncurses.
This task depends upon

Closed by  Greg (dolby)
Thursday, 19 June 2008, 12:14 GMT
Reason for closing:  Won't fix
Comment by Greg (dolby) - Wednesday, 18 June 2008, 21:02 GMT
Hm that must have happened with latest release to address utf8 issues. AFAIR previous version was much different.
Comment by Tobias Kieslich (tobias) - Wednesday, 18 June 2008, 21:38 GMT
Mutt was build against slang due to user requests and to address utf-8 issues. I see that this is a trade off to the colour issue you experience, however the colour issues can be way easier resoved, aka resolved at all by changing the configuration.
I attached a file that you can easily copy into your .muttrc or source it from there.
EDIT:----------------------------------------
slang also allows the terminal to be resized once mutt is already opened
Comment by Loui Chang (louipc) - Wednesday, 18 June 2008, 21:59 GMT
Thanks for the colour config.
Can you link me to a disccussion about utf-8 issues? Thanks.

Also the resizing thing seems to work fine with ncurses.
Comment by Tobias Kieslich (tobias) - Wednesday, 18 June 2008, 22:37 GMT
As for the resizing stuff, I just built it agains ncurses and the opened mutt and despite the terminal being bigger the usual mutt was in a 80x25 size. Closing it, the resizing the terminal and reopen mutt solves it. I had this issue with ncurses all of the time and it is really annoying. I never had it with slang.
The utf-8 was reported by users from asian coutries straight into my inbox several times. After I encouraged some of them to rebuild mutt against slang the complaints went away. So eventually I opted for a general build against slang as it involves less trouble, except for the colour issu which can be resolve by a config file for good.
Comment by Loui Chang (louipc) - Thursday, 19 June 2008, 01:20 GMT
Hmm what terminal are you using? I can't seem to reproduce it
in any terminal.

What were their issues exactly? I'd like to investigate if
you can dig up what the issues were. I think in general utf-8
problems belong to the terminal or to font configurations.

I did do some googling and it seemed some issues with ncurses
mutt and utf-8 might have been solved about four years ago.
Comment by Tobias Kieslich (tobias) - Thursday, 19 June 2008, 01:56 GMT
Okay lemme try to explain what happens, it is some ugly issue with ncurses in general:
Open a terminal (I reproduced with xterm and rxvt-unicode) in standard size, open an ncurses application (htop will do)
While it is open, resize the terminal, the application might or might not resize. Close the application. Open mutt with ncurses.
Screenie attached
It will be shrunk to 80x25 even though the term is bigger. Now if I resize the term, mutt will redraw and you will see most of the stuff but not always completely!
some vertical bars might be drawn longer than 80 chars some might not be, I have not completely figured out how that is triggered.
You can repeat that as long as you want. Close and reopen it, it's back to 80x25. The only way to change it for good is to close mutt, resize the terminal and then reopen mutt.
You will have to do that anytime you wanna resize your terminal. Slang on the other side never had that issue.
For the encoding, I had only reports and some screenies, but never actually reproduced the issue. It was also reported by users I trust over the years.
Also, the resizing is annoying enough to switch to slang.
Comment by Loui Chang (louipc) - Thursday, 19 June 2008, 03:28 GMT
Yeah that might be annoying.
Freaking computers! I can't reproduce this.
Well at least someone can confirm a similar problem
http://dev.mutt.org/trac/ticket/2960
Comment by Tobias Kieslich (tobias) - Thursday, 19 June 2008, 06:17 GMT
Well, all in all it was a reasonable user request and the fact that the colour issue can be resolved by configs, the resizing not. I'm still pretty confident it was a good decision to switch to slang. For those who neded it the utf-8 was a bonus, however I agree here that the utf-8 probably can be resolved by a proper configs. It is also stated now by you that the curses version does not show the behaviour, I had to request about it and was able to reproduce it though. It probably is triggered by some setting or combination of software installed. However I have no clue what and as it is it can;t be fixed. Except with slang. We might switch back once it is resolved. But for now it stays with slang.

Loading...