Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10548 - libgdiplus cannot be build

Attached to Project: Arch Linux
Opened by Anonymous Submitter - Saturday, 31 May 2008, 18:47 GMT
Last edited by Greg (dolby) - Saturday, 31 May 2008, 20:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Building libgdiplus seems to need an older version of autoconf than that in the repo.


libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize: `/usr/share/aclocal/libtool.m4'
libtoolize: `/usr/share/aclocal/ltoptions.m4'
libtoolize: `/usr/share/aclocal/ltversion.m4'
libtoolize: `/usr/share/aclocal/ltsugar.m4'
libtoolize: `/usr/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
/usr/share/aclocal/smpeg.m4:13: warning: underquoted definition of AM_PATH_SMPEG
/usr/share/aclocal/smpeg.m4:13: run info '(automake)Extending aclocal'
/usr/share/aclocal/smpeg.m4:13: or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
configure.in:69: error: AC_SUBST: `FONTCONFIG-CONFIG' is not a valid shell variable name
../../lib/autoconf/programs.m4:178: AC_PATH_PROG is expanded from...
configure.in:69: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
aclocal.m4:14: error: this file was generated for autoconf 2.61.
You have another version of autoconf. If you want to use that,
you should regenerate the build system entirely.
aclocal.m4:14: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
aclocal.m4:14: error: this file was generated for autoconf 2.61.
You have another version of autoconf. If you want to use that,
you should regenerate the build system entirely.
aclocal.m4:14: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
automake: autoconf failed with exit status: 63
configure: error: cannot run /bin/sh ./config.sub
make: *** Keine Targets angegeben und keine �make�-Steuerdatei gefunden. Schluss.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce: Try to build libgdiplus with autoconf 2.62 installed.
This task depends upon

Closed by  Greg (dolby)
Saturday, 31 May 2008, 20:10 GMT
Reason for closing:  Fixed
Comment by Isenmann Daniel (ise) - Saturday, 31 May 2008, 19:31 GMT
delete the lines with "aclocal, autoconf and automake" then it will compile. I will change it in the next update. There will be a new mono version out the next days/weeks...
Comment by Anonymous Submitter - Saturday, 31 May 2008, 19:52 GMT
Fix did not work.

libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize: `/usr/share/aclocal/libtool.m4'
libtoolize: `/usr/share/aclocal/ltoptions.m4'
libtoolize: `/usr/share/aclocal/ltversion.m4'
libtoolize: `/usr/share/aclocal/ltsugar.m4'
libtoolize: `/usr/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
configure: error: cannot run /bin/sh ./config.sub
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
==> FEHLER: Build fehlgeschlagen.
Comment by Isenmann Daniel (ise) - Saturday, 31 May 2008, 19:52 GMT
Sorry, the libtoolize line must be deleted also....
Comment by Anonymous Submitter - Saturday, 31 May 2008, 20:03 GMT
  • Field changed: Percent Complete (100% → 0%)
Fix did not work.

libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize: `/usr/share/aclocal/libtool.m4'
libtoolize: `/usr/share/aclocal/ltoptions.m4'
libtoolize: `/usr/share/aclocal/ltversion.m4'
libtoolize: `/usr/share/aclocal/ltsugar.m4'
libtoolize: `/usr/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
configure: error: cannot run /bin/sh ./config.sub
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
==> FEHLER: Build fehlgeschlagen.
Comment by Isenmann Daniel (ise) - Saturday, 31 May 2008, 20:04 GMT
Delete the libtoolize line in the PKGBUILD. It fixed the bug. I have no problems here.
Comment by Anonymous Submitter - Saturday, 31 May 2008, 20:06 GMT
Sorry i pushed the reload button of my browser and the tasks got reopened withe the same text as before. Did not want that. The fix seems to work, I am currently building.

Loading...