Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10537 - NVIDIA Cuda 2.0 does not works

Attached to Project: Arch Linux
Opened by sd (vfork_0x00f) - Friday, 30 May 2008, 02:31 GMT
Last edited by Pierre Schmitz (Pierre) - Saturday, 28 February 2009, 17:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Applications developped with NVIDIA Cuda 2.0 does not works. They all fail with a message "There is no device supporting CUDA."

There is a simple workaround :

Create a simlink
sudo ln -s /usr/lib/libcuda.so.1 /usr/lib/libcuda.so

Would it be possible to create this link when the package is installed ?

Additional info:
* package version(s)

nvidia-utils 173.14.05-1


* config and/or log files etc.


Steps to reproduce:

install cuda 2.0 beta from the nvidia web site
compile and execute any exemple from the SDK.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Saturday, 28 February 2009, 17:45 GMT
Reason for closing:  Fixed
Comment by Greg (dolby) - Tuesday, 12 August 2008, 22:18 GMT
Is this fixed with latest nvidia?
Comment by sd (vfork_0x00f) - Tuesday, 12 August 2008, 22:56 GMT
there is still no /usr/lib/libcuda.so link to /usr/lib/libcuda.so.1
Comment by Donald Beck (Pudge) - Thursday, 15 January 2009, 02:49 GMT
I was trying to run a Windows XP app through WINE that requires CUDA 2.0. I am using the nvidia-180.22 driver from testing. It didn't work and yielded the following error message:

initializing Nvidia gpu library
cudaMalloc CUDAStream::allocate failed feature is not yet implemented.

As stated by the originator of this bug, Running

ln -s /usr/lib/libcuda.so.1 /usr/lib/libcuda.so

Fixed the problem. Just as a FYI, downloading NVIDIA-Linux-x86-180.22-pkg0.run and running this script to compile and install the Nvidia kernel module did include the aforementioned symlink and worked. running the script with the --uninstall flag removed the kernel module and the symlink. When I subsequently installed nvidia-180.22 from testing via pacman, it didn't work due to the missing link.

Loading...