Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10529 - 2008.04-RC Fails to Load default grub menu at installation boot

Attached to Project: Arch Linux
Opened by Michael J. Abel (zeifertstc) - Thursday, 29 May 2008, 08:19 GMT
Last edited by Aaron Griffin (phrakture) - Friday, 12 December 2008, 18:25 GMT
Task Type Bug Report
Category Installation
Status Closed
Assigned To Simo Leone (neotuli)
Aaron Griffin (phrakture)
Architecture i686
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

[NOTE: This bug does NOT apply to 2007.08-2, this bug DOES apply to 2008.04-RC which will not boot properly on my system.]

CD does boot at startup as in, it spins up and gets to grub. Grub then acts dumb and seems to "misplace" the kernel it's supposed to be loading. In other words I sit here looking at:

grub>_

My original question under Installation on bbs.archlinux.org was for the commands I should toss at the installer to achieve the desired result of seeing the fancy boot menu that was designed for this ISO. However, I guess I should try to help get this thing fixed while I'm reporting this bug.

Additional info:
System Specs:
eMachines W3503 (base system)
3.33GHz Intel Celeron D Core 2 Duo
(add in) 1GB RAM
(add in) 256MB ATI X1650
(add in) Sound Blaster Audigy 24-bit surround sound card
(add in) Netgear WG311v3 wireless network card
1x LITE-ON DVD+/-RW (original)
(add in) 1x NEC_DVD DVD+/-RW
Original 160GB HDD
(add in) 20GB HDD
(add on [usb]) Western Digital 250GB External HDD
* package version(s)
Unknown

* config and/or log files etc.
Not Applicable

Steps to reproduce:

Try booting up on a system configured as close to mine as possible. Since I am sure that I am either the first or among the very few who have tried this new installer and had it fail, it may just be a piece of hardware that I have that not many others do?

I do not see, however, how a piece of hardware could make a pre-configured piece of software "lose" it's kernel and sit waiting for instruction like this. It is rather strange and unusual to me. Since I have never had to pass kernel commands to Grub manually before, it's a new thing to me. If I knew what to toss at it, this might not be an issue.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Friday, 12 December 2008, 18:25 GMT
Reason for closing:  Deferred
Additional comments about closing:  Old disk, obsolete
Comment by Aaron Griffin (phrakture) - Thursday, 29 May 2008, 16:15 GMT
Actually, this is most likely hardware related. When I began making the grub disk, I found some very unclear documentation about grub being able to boot some systems. I was under the assumption that this was only older systems.

Would you mind checking to see if another grub-based boot disk works? Like this? http://www.supergrubdisk.org/
Comment by Michael J. Abel (zeifertstc) - Saturday, 31 May 2008, 21:41 GMT
Super Grub Disk also fails to run any further than:

grub>_

Since all other Arch installers are currently non-functional for some reason or other, I am left with a feeling of withdrawal from Archlinux. Duke x86_64 fails to cache packages and so does "Don't Panic" x86. This one, of course, won't let me get far enough in to actually see if it will install.

Guess I am one of very few numbers affected by this malcontent hardware problem. If I may ask, what hardware issue is involved here? It isn't something cheaply (or freely) remedied, is it?
Comment by Mick (lunix) - Sunday, 08 June 2008, 05:33 GMT
I have a Dell Inspiron 1420 notebook with the same problem.
Intel Core2 Duo T7500 DVD-RW.......

Mick
Comment by Michael J. Abel (zeifertstc) - Sunday, 08 June 2008, 09:31 GMT
With this information included, going by just the information provided, the only thing we've got in common is the Core 2 Duo processor. But, it doesn't make sense that the processor would make it drop to the grub prompt. There must be something more.
Comment by Glenn Matthys (RedShift) - Tuesday, 17 June 2008, 14:45 GMT
You are sure that

1) The ISO you downloaded isn't corrupt
2) Tried with a different CD-R or even a different brand
3) Used another CD-ROM drive

Most CD-writing software have an option to check the integrity of the burnt CD, try and enable that option. Otherwise use dd to copy the contents of the CD-ROM back to the harddisk and MD5-sum it. It should match the MD5 sum of the ISO you downloaded.

(By the way you can still install Arch Linux using knoppix)
Comment by Simo Leone (neotuli) - Friday, 20 June 2008, 06:53 GMT
The processor issue may be a coincidence, but more importantly, the chipset and/or bios may be the same or similar. You know, for a while there we were all happy no one had hardware that didn't speak grub-on-cd, way to ruin it guys ;P
We need to seriously look into this some more, and consider providing isolinux disks on the side if we can't figure anything else out (from a technical standpoint, it shouldnt be hard to do).

In the meantime, your hardware sounds pretty new, and might be able to boot off of a USB drive, I'd recommend trying that for the time being.
Comment by Glenn Matthys (RedShift) - Friday, 20 June 2008, 08:53 GMT
I remember reports earlier with GRUB CD's that didn't boot, but did boot with isolinux. (Tpowa has created an installer ISO with GRUB before).

But we haven't heard from the original reporter after my post from 17 june. Maybe we should wait after he's tried what I suggested?
Comment by Aaron Griffin (phrakture) - Friday, 20 June 2008, 16:19 GMT
Yeah, while grub on CD is awesome, there is some hardware that doesn't load it right. Providing secondary isolinux images is probably a good idea.

Can you guys check to see if booting from a USB stick works in the interim?
Comment by Michael J. Abel (zeifertstc) - Saturday, 21 June 2008, 12:23 GMT
The disc integrity checked out alright, both CD/DVD writers in the system loaded the disc the exact same way on both Arch Linux Grub Iso and Super Grub discs. Not that Knoppix is totally terrible or anything, the knoppix discs I have don't come with direction for acting as a host to the installation of another distro. If instruction can be provided for that procedure, I would be most interested.

As per neotuli's post about the possibility of USB booting, my bios does not seem to offer that capability. (which saddens me to no end, mind you) Since the bios doesn't seem to support that functionality and I have no floppy option for this particular setup, I'd prefer the standard isolinux discs as they generally work quite well.

I just wish I could see the "awesome" from this particular disc. The menu, and options on the menu, are of much interest to me. On a side note and at the risk of making an installer iso that much larger, what are the chances of creating an Ubuntu-esque approach to installing arch. Perhaps a fluxbuntu based livecd with minimal options so that a system can be installed from livecd with the option of referring to a wiki via dillo or similar lightweight browser app? I used to have my laptop to fall back on for necessarily vital info and am now unable to do so. It is my opinion that a disc with the option to install the LiveCD setup or perform a netinst would be beneficial to users with limited download capability. (ie., 256k DSL connection with download rates at a max of 32.1kb/s)
Comment by Glenn Matthys (RedShift) - Saturday, 21 June 2008, 12:53 GMT
Installing Arch Linux from knoppix is easy, just download the pacman source from http://www.archlinux.org/pacman/, compile & install it, then use the --root option to install packages (see man pacman for that). If you don't want to compile pacman you can probably download the pacman package for archlinux, extract its contents and use the pacman.static that comes with that tar gz.
Comment by Max L (brynjolf) - Saturday, 21 June 2008, 14:26 GMT
I noticed that the installer creates one newline too much on the default option.
So instead of eg kernel=blablalbla lalalalallala
its
kernel=blablalbla
lalalalallala

Check your menu.lst
Is this related or another bug?
Comment by Glenn Matthys (RedShift) - Saturday, 21 June 2008, 16:02 GMT
Installing Arch Linux from knoppix is easy, just download the pacman source from http://www.archlinux.org/pacman/, compile & install it, then use the --root option to install packages (see man pacman for that). If you don't want to compile pacman you can probably download the pacman package for archlinux, extract its contents and use the pacman.static that comes with that tar gz.
Comment by Matti Lahtinen (wor) - Sunday, 22 June 2008, 19:23 GMT
Having the same problem with Intel Q9450 and Asus P5E WS PRO motherboard.
Comment by Xrhstos periergos (xandrio) - Saturday, 12 July 2008, 14:07 GMT
I seem to have the same problem

Also running a C2duo 7200 on asus p5q mobo (p45 chipset)
Comment by Federico Stafforini (fede) - Sunday, 13 July 2008, 00:53 GMT
I second Max L's comment: the installer seems to add an unnecessary newline inside the kernel line within /boot/grub/menu.lst
I suspect this might be related to editing the kernel line:

* after editing the main entry (ie default archlinux 0 option, to add vga=773) the this entry was broken but,
* the fallback boot entry was not edited and not affected
* this happened to me at least 3 times in 3 different installations, but I always add vga=773 to the main entry, haven't checked if it doesn't happen otherwise

Naive suggestion: I chose nano as an editor. Are we using nano -w to edit menu.lst? Because adding the vga=773 option to the default entry just made it longer than 88 chars (my console screen width)!
Comment by Alexej Diesner (alexejD) - Sunday, 13 July 2008, 17:27 GMT
I have the same problem on the older ACER Aspire 1300 Notebook:
mobile AMD Athlon(tm) XP 1400+
IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C
Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 80)
CD-ROM TOSHIBA DVD-ROM SD-R2212

I had to use Archlinux-i686-2008.03-1-archboot.ftp.iso instead.
Comment by Xrhstos periergos (xandrio) - Sunday, 13 July 2008, 18:31 GMT
Well , i downloaded the iso through torrent and it seems to solve the problem so i guess it has something to do with the image. Check the MD5s

Loading...