Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10430 - Xorg crashes on startup (with intel driver 2.3)

Attached to Project: Arch Linux
Opened by Sander Jansen (GogglesGuy) - Friday, 16 May 2008, 14:39 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 16 September 2008, 06:30 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Aaron Griffin (phrakture)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

After my last upgrade, Xorg crashes on startup:

These were the last packages that were upgraded (just in case some packages are missing and not on the servers yet):

[2008-05-16 09:18] synchronizing package lists
[2008-05-16 09:18] starting full system upgrade
[2008-05-16 09:20] upgraded inputproto (1.4.2.1-1 -> 1.4.3-1)
[2008-05-16 09:20] upgraded libgl (7.0.3rc2-1 -> 7.0.3-2)
[2008-05-16 09:20] upgraded libx11 (1.1.3-6 -> 1.1.4-2)
[2008-05-16 09:20] upgraded libxinerama (1.0.2-1 -> 1.0.3-1)
[2008-05-16 09:20] upgraded libxkbfile (1.0.4-1 -> 1.0.5-1)
[2008-05-16 09:20] upgraded libxv (1.0.3-1 -> 1.0.4-1)
[2008-05-16 09:20] upgraded lvm2 (2.02.33-1 -> 2.02.36-1)
[2008-05-16 09:20] upgraded mesa (7.0.3rc2-1 -> 7.0.3-2)
[2008-05-16 09:20] upgraded printproto (1.0.3-1 -> 1.0.4-1)
[2008-05-16 09:20] installed intel-dri (7.0.3-1)
[2008-05-16 09:20] upgraded xf86-video-intel (2.2.1-2 -> 2.3.1-1)
[2008-05-16 09:20] upgraded xorg-server (1.4.0.90-9 -> 1.4.0.90-13)
[2008-05-16 09:20] upgraded xproto (7.0.11-1 -> 7.0.12-1)
[2008-05-16 09:20] upgraded xtrans (1.0.4-1 -> 1.2-1)


The Xorg.log reports:

(II) Loading sub module "ddc"
(II) LoadModule: "ddc"(II) Module "ddc" already built-in
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"(II) Module "i2c" already built-in
(II) intel(0): Output VGA using monitor section VGA Output
(II) intel(0): I2C bus "CRTDDC_A" initialized.
(II) intel(0): Output LVDS using monitor section LVDS Output
(II) intel(0): I2C bus "LVDSDDC_C" initialized.
(II) intel(0): Attempting to determine panel fixed mode.
(II) intel(0): I2C device "LVDSDDC_C:ddc2" registered at address 0xA0.

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6a) [0x4a035a]
1: /lib/libc.so.6 [0x2afbd1f13ec0]
2: /usr/bin/X(xf86DDCApplyQuirks+0x26) [0x4b5196]
3: /usr/bin/X(xf86OutputGetEDID+0x2f) [0x4b072f]
4: /usr/lib/xorg/modules/drivers//intel_drv.so(i830_ddc_get_modes+0x11) [0x2afbd3ab01d1]
5: /usr/lib/xorg/modules/drivers//intel_drv.so(i830_lvds_init+0x2a9) [0x2afbd3aacb39]
6: /usr/lib/xorg/modules/drivers//intel_drv.so [0x2afbd3aa85f5]
7: /usr/bin/X(InitOutput+0x9cb) [0x4698eb]
8: /usr/bin/X(main+0x2c6) [0x435ec6]
9: /lib/libc.so.6(__libc_start_main+0xfa) [0x2afbd1f0018a]
10: /usr/bin/X(FontFileCompleteXLFD+0x279) [0x435369]

Fatal server error:
Caught signal 11. Server aborting

I attached the full Xorg log and also my xorg.conf
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 16 September 2008, 06:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in testing
Comment by Sander Jansen (GogglesGuy) - Friday, 16 May 2008, 14:48 GMT
Seems the synaptics module is causing the crash. If I don't load that module, everything seems to come up fine...
Comment by Aaron Griffin (phrakture) - Friday, 16 May 2008, 16:36 GMT
Could you try rebuilding synaptics against the newest xorg packages? I have a guess that it just needs a rebuild
Comment by Jan de Groot (JGC) - Friday, 16 May 2008, 16:59 GMT
That doesn't make sense to me, your backtrace shows something in the intel driver.
Comment by Sander Jansen (GogglesGuy) - Friday, 16 May 2008, 17:15 GMT
I know the backtrace shows the intel driver crashing, but removing the synaptics module makes it not crash.
I did a rebuild of the synaptics package, but no luck. ( I downloaded all the files from the package and did a makepkg and a pacman -U packagename).
Comment by Jan de Groot (JGC) - Friday, 16 May 2008, 20:38 GMT
What happens when you downgrade xf86-video-intel to the previous version?
Comment by Sander Jansen (GogglesGuy) - Friday, 16 May 2008, 22:00 GMT
The older intel driver (xf86-video-intel-2.2.1-2) works.
Comment by ruinevil (ruinevil) - Saturday, 17 May 2008, 13:36 GMT
RgbPath "/usr/share/X11/rgb" <--- when I was playing with the git version of X-everything, Xorg didn't like this line anymore. If synaptics isnt build for a particular Xorg-server, it will just skip it. It shouldn't be a show stopper.
Comment by Jan de Groot (JGC) - Saturday, 17 May 2008, 17:28 GMT
The whole issue with rgbpath is that the default and correct path is hardcoded in the X server, you can override it by config, but when you do it, it should be the correct path. In this case /usr/share/X11/rgb is the correct path, so that shouldn't be the issue.

Comment by ruinevil (ruinevil) - Sunday, 18 May 2008, 02:21 GMT
Hmmm.... where did he get these packages anyways?
Comment by Jan de Groot (JGC) - Sunday, 18 May 2008, 10:07 GMT
These packages are built for amd64 only at this moment.
Comment by niQo (niQo) - Friday, 23 May 2008, 10:54 GMT
I have a similar problem with latest intel driver release (xf86-video-intel-2.3.1), see this bug
http://bugs.freedesktop.org/show_bug.cgi?id=15933
I revert to previous version (2.3.0) and my system no more hangs at startup.
Comment by Greg (dolby) - Saturday, 21 June 2008, 15:43 GMT
Can you try xf86-video-intel 2.3.2-1?
Comment by Sander Jansen (GogglesGuy) - Saturday, 21 June 2008, 22:59 GMT
Same problem with 2.3.2-1. Crash goes away if I don't load the synaptics module...

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6a) [0x4a03ca]
1: /lib/libc.so.6 [0x7f693c3a8150]
2: /usr/bin/X(xf86DDCApplyQuirks+0x26) [0x4b51c6]
3: /usr/bin/X(xf86OutputGetEDID+0x2f) [0x4b075f]
4: /usr/lib/xorg/modules/drivers//intel_drv.so(i830_ddc_get_modes+0x11) [0x7f693a9153f1]
5: /usr/lib/xorg/modules/drivers//intel_drv.so(i830_lvds_init+0x2a9) [0x7f693a911c89]
6: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f693a90d795]
7: /usr/bin/X(InitOutput+0x9cb) [0x4698db]
8: /usr/bin/X(main+0x2c6) [0x435ec6]
9: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f693c3943f6]
10: /usr/bin/X(FontFileCompleteXLFD+0x279) [0x435369]

Fatal server error:
Caught signal 11. Server aborting

Comment by ArchPetr (ArchPetr) - Monday, 11 August 2008, 13:56 GMT
Good afternoon men,
I tried install fresh and clean ArchLinux and I failed on startx. I have Lenovo 3000 N100 with Intel GMA950 (http://www-307.ibm.com/pc/support/site.wss/quickPath.do?quickPathEntry=076866G).

1) When I run startx as root, twm occur. When I run startx as power user, xserver does not start. I catch two traces.

2) Gnome-session or startlxde fails and can not open xserver under root or power user.

3) I found that if I run xinit as power user, xserver failed. If I run strace xinit as power user, I can see X cursor on the screen.

Is here some workaround to start xserver with GMA950 on freshly installed ArchLinux? Intel, i810, fbdev, vesa or vga driver failed too. Disable glx, dri, type1 does not help.

P.S. Before half year after fresh install startx with gnome works honestly. Now nothing :'(.
Comment by Nuked (Nuked) - Friday, 05 September 2008, 06:20 GMT
I have a similar issue with x86.. I remove the selected areas from the xorg.conf and I get a load of crap. Ill attempt to paste what exactly is borked asap.
Comment by Jan de Groot (JGC) - Friday, 05 September 2008, 08:10 GMT
Does this still happen with xorg from testing? (you might want to disable input hotplugging, see the other bugreports about it).
Comment by Nuked (Nuked) - Saturday, 06 September 2008, 05:17 GMT
JGC, I think I may have found a sort of solution.

I was getting errors regarding rgbpath, so I went ahead and commented these areas out:

#Section "Files"
# RgbPath "/usr/share/X11/rgb"
# ModulePath "/usr/lib/xorg/modules"
# FontPath "/usr/share/fonts/misc"
# FontPath "/usr/share/fonts/100dpi:unscaled"
# FontPath "/usr/share/fonts/75dpi:unscaled"
# FontPath "/usr/share/fonts/TTF"
# FontPath "/usr/share/fonts/Type1"
#EndSection

Then it bitched about not being able to load modules, so I commented
# Load "record"
# Load "type1"

and changed the Driver field to intel instead of i810. Then there was a complaint regarding not having evdev installed, so I installed the one from testing, ran startx and got a e17 session. However, kdm and gdm are no go at this point, but Ill try to see what's going on soon. (seems to be a totally different issue from what I initially thought was going on. This "fixes" any intel i915 or equivalent cards
Comment by Sander Jansen (GogglesGuy) - Monday, 08 September 2008, 14:38 GMT
It seems to be working again.
Comment by thiago (thiago907) - Wednesday, 10 September 2008, 14:32 GMT
well... no exactly like my problem but still related with xorg and intel driver: http://bbs.archlinux.org/viewtopic.php?id=54890
Comment by Jan de Groot (JGC) - Monday, 15 September 2008, 17:06 GMT
Is the original bug fixed with xf86-video-intel 2.4.2, xf86-input-synaptics 0.15.2 and xorg-server 1.5.0 from testing?
Comment by Sander Jansen (GogglesGuy) - Monday, 15 September 2008, 18:31 GMT
I believe it does, but since I switched to the hal based X server (no Xorg.conf file), I'm waiting for xf86-input-synaptics 0.15.2 to be come available for x86_64, before I can confirm it will work without problems...
Comment by Sander Jansen (GogglesGuy) - Monday, 15 September 2008, 18:51 GMT
Adding the missing fdi file manually, the combination of xf86-video-intel 2.4.2, xf86-input-synaptics 0.15.0 and xorg-server 1.5.0 from testing works great. You may close this bug report.

Loading...