Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10286 - xine-lib with internal ffmpeg produces x264 green artifacts

Attached to Project: Arch Linux
Opened by (N/A) (wantilles) - Saturday, 26 April 2008, 09:37 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 30 July 2008, 20:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:


Additional info:
* package version(s)

1.1.12-1

Steps to reproduce:

Play almost any video that contains a x264 video stream.

Green artifacts will appear from the left edge of the screen.

This is a known upstream bug of xine-lib, existing from October 2006.

It has been reported in many other distributions since:

ie:

https://bugs.launchpad.net/ubuntu/+source/xine-lib/+bug/123476

It is due to the fact that the internal ffmpeg code that xine-lib contains is very outdated and old.

Solution:

Build xine-lib with external ffmpeg support.

ie.

depends=('libgl' 'libxvmc' 'esd' 'flac>=1.1.4' 'libvorbis' 'sdl' 'libmng' 'libtheora'
'libxcb' 'wavpack' 'ffmpeg')

./configure --prefix=/usr --with-w32-path=/usr/lib/win32 \
--with-xv-path=/usr/lib --with-libflac --with-wavpack \
--without-arts --without-jack --without-speex \
--disable-gnomevfs --without-pulseaudio --disable-aalib --disable-modplug \
--with-external-ffmpeg

A ready PKGBUILD is here:

http://aur.archlinux.org/packages.php?ID=16622
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 30 July 2008, 20:17 GMT
Reason for closing:  Implemented
Comment by Eric Belanger (Snowman) - Wednesday, 30 July 2008, 02:41 GMT
xine-lib-1.1.14-2 uses external ffmpeg. Please test and let me know if it fixes the green artifacts problem. The x264 samples I could find on the internet either weren't playing at all or were working fine regardless of internal/external ffmpeg.
Comment by (N/A) (wantilles) - Wednesday, 30 July 2008, 20:08 GMT
xine-lib-1.1.14-2 that uses external ffmpeg produces no green artifacts.

Therefore I consider this bug resolved.

Please close it.
Comment by Eric Belanger (Snowman) - Wednesday, 30 July 2008, 20:17 GMT
OK. Please remove xine-lib-external-ffmpeg from AUR. I presume that it is no longer needed.

Loading...