Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#10274 - Include a PKGBUILD-perl.proto

Attached to Project: Pacman
Opened by Gavin Bisesi (Daenyth) - Thursday, 24 April 2008, 18:40 GMT
Last edited by Allan McRae (Allan) - Saturday, 09 August 2008, 15:13 GMT
Task Type Feature Request
Category Scripts & Tools
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version 3.1.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It would be nice to have a .proto file in /usr/share/pacman which follows the perl policy.

http://wiki.archlinux.org/index.php/Perl_Policy
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 09 August 2008, 15:13 GMT
Reason for closing:  Implemented
Comment by Dan McGee (toofishes) - Thursday, 24 April 2008, 20:06 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Documentation → Scripts & Tools)
  • Task assigned to Travis Willard (Cerebral)
I believe these are a part of the ABS package now, so assigning to Travis. Seems like a good idea to me.
Comment by Travis Willard (Cerebral) - Thursday, 24 April 2008, 20:08 GMT
sounds like a good idea.
Comment by Aaron Griffin (phrakture) - Thursday, 24 April 2008, 20:09 GMT
I imagine we'd also want similar for the gnome standards (those are in the wiki too). gedit is a good PKGBUILD for this.
Comment by Travis Willard (Cerebral) - Thursday, 24 April 2008, 20:11 GMT Comment by Travis Willard (Cerebral) - Thursday, 24 April 2008, 20:12 GMT
http://wiki.archlinux.org/index.php/Arch_Packaging_Standards -- heck, one for every category at the bottom of this page probably couldn't hurt
Comment by Gavin Bisesi (Daenyth) - Thursday, 24 April 2008, 22:41 GMT Comment by Gavin Bisesi (Daenyth) - Thursday, 24 April 2008, 22:44 GMT
Woops, didn't see that included in the last post... Feel free to delete these 2 replies.
Comment by Francois Charette (Firmicus) - Friday, 25 April 2008, 17:06 GMT
I have put such a PKGBUILD-perl.proto (for the new perl policy) on the community cvs repo 4 weeks ago: http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/PKGBUILD-perl.proto?cvsroot=AUR&only_with_tag=CURRENT
Feel free to improve it. I'll remove it if it becomes part of the abs pkg.
Comment by Gavin Bisesi (Daenyth) - Friday, 25 April 2008, 21:03 GMT
my only issue with that .proto is that using $pkgname in the source url won't work because of the differences in Arch vs CPAN naming. Do we want to endorse a custom variable there such as "_perlname='Foo::Bar'", or should we say "Just hardcode the url"?
Comment by Xavier (shining) - Wednesday, 11 June 2008, 15:21 GMT
The above link is dead now, here is the new one : http://repos.archlinux.org/viewvc.cgi/community/?root=community
I think it would be a good idea to move all the prototypes from there to abs package (and so remove them from community repo).
Comment by Gavin Bisesi (Daenyth) - Thursday, 19 June 2008, 18:29 GMT
I agree, I was a little confused when I saw the .proto files in /var/abs/community, as opposed to /usr/share/pacman.
Comment by Allan McRae (Allan) - Sunday, 06 July 2008, 08:45 GMT
Anyone have a good example package to base lisp/java proto PKGBUILD on?
Comment by Allan McRae (Allan) - Saturday, 09 August 2008, 15:13 GMT
There are additional prototypes in abs-2.2. For any further additions, open a new bug report with an example attached.

Loading...