Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#10218 - extra/tcsh 6.15.01-2 PKG_CONFIG_PATH: Undefined variable.

Attached to Project: Arch Linux
Opened by Johnny Bravo (Johnny_B) - Friday, 18 April 2008, 18:13 GMT
Last edited by Eric Belanger (Snowman) - Monday, 01 September 2008, 21:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I get this weird error after running pacman -Suy.

When logging in the shell prompts: "PKG_CONFIG_PATH: Undefined variable." and then stops reading the rest of my tcsh configuration. Leaving a boring standard shell.

I have tried creating a new user with standard tcsh configuration, same there. Tried to adding "setenv PKG_CONFIG_PATH /usr/lib/pkgconfig" to both .tschrc and .login, no difference.

Additional info:
* extra/tcsh 6.15.01-2
Prompts on login: "PKG_CONFIG_PATH: Undefined variable."

Steps to reproduce:
Start tcsh (/usr/bin/tcsh)
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 01 September 2008, 21:04 GMT
Reason for closing:  Not a bug
Additional comments about closing:  bug is no longer relevant: kde.csh has been removed.
Comment by Johnny Bravo (Johnny_B) - Friday, 18 April 2008, 18:53 GMT
echo setenv PKG_CONFIG_PATH /usr/lib/pkgconfig > /etc/csh.env

The error comes from: /etc/profile.d/kde.csh in line #4:

Since PKG_CONFIG_PATH isn't set, :$PKG_CONFIG_PATH will result in an exit

Works now. Is this the right way to do it?
Comment by Eric Belanger (Snowman) - Monday, 21 July 2008, 19:32 GMT
Try the following and let me know if it fixes it:
In /etc/profile.d/kde.csh, replace:



if ( ! $?PKG_CONFIG_PATH ) then
setenv PKG_CONFIG_PATH $KDEDIR/lib/pkgconfig

Comment by Eric Belanger (Snowman) - Tuesday, 29 July 2008, 02:31 GMT
The /etc/profile.d/kde.csh file no longer exist since the update to KDE4. It seems that it was the cause of the problem. Can this bug be closed?