Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10159 - jre should depend on libXtst

Attached to Project: Arch Linux
Opened by Josh Harding (TheAmigo) - Friday, 11 April 2008, 22:35 GMT
Last edited by Eduardo Romero (kensai) - Friday, 04 July 2008, 16:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jason Chu (jason)
Eduardo Romero (kensai)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The jre package should depend on libXtst

Additional info:
* Discovered with jre-6u5-1 and firefox3-3.0b4 installed
* When firefox is started from a terminal window, browsing to a page with a java applet causes an error message to be displayed. The error complains about a missing libXtst.so (sorry, I don't have the exact text available).
* pacman -S libxtst then restarting firefox fixed the problem.

Steps to reproduce:
All java applets fail to launch in the browser.
This task depends upon

Closed by  Eduardo Romero (kensai)
Friday, 04 July 2008, 16:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Added message for libxtst dependencie in order to have java applets working in firefox.
Comment by Jason Chu (jason) - Saturday, 10 May 2008, 18:12 GMT
The problem is that some people might want to install jre on a headless server. Then libxtst is just extra cruft for them.

Since jre doesn't need libxtst for it's most straightforward dependencies, I'm going to add an install message that tells you to install it if you want java applets to work. Eventually when we get optdepends fully enabled, I will list it there.

Loading...