Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10147 - gnome clock panel applet fails to load

Attached to Project: Arch Linux
Opened by Flavien Bridault (vlaaad) - Friday, 11 April 2008, 09:47 GMT
Last edited by Jan de Groot (JGC) - Friday, 11 April 2008, 12:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since I upgraded to gnome 2.22, the gnome clock panel applet fails to load. I just get the message that the applet can't load. I first thought it was a configuration problem, but I tried with a fresh new user and the problem remains. :-/


Additional info:
* gnome-panel 2.22.0-1
* I get the following in ~/.xsessions-errors :
** (gnome-panel:8606): WARNING **: panel-applet-frame.c:1268: failed to load applet OAFIID:GNOME_ClockApplet:
System exception: IDL:Bonobo/GeneralError:1.0 : Le processus fils n'a pas renvoyé de message d'erreur, une erreur inconnue s'est produiteconfig and/or log files etc.


Steps to reproduce:
Add the clock applet in a gnome panel.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 11 April 2008, 12:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2.22.1.2-2, The new clock applet code doesn't like to get optimized with -O2.
Comment by Jan de Groot (JGC) - Friday, 11 April 2008, 11:01 GMT Comment by Jan de Groot (JGC) - Friday, 11 April 2008, 11:43 GMT
Workaround is to do "ln -sf /usr/share/zoneinfo/$TIMEZONE /etc/localtime", where $TIMEZONE is the one set in /etc/rc.conf. As rc.sysinit replaces this file on every boot and shutdown, it will get reverted on the next boot. I hope to have a working permanent fix in the weekend.

Loading...