Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10095 - Unable to install gstreamer0.10-base

Attached to Project: Arch Linux
Opened by Ondřej Konečný (andrew9888) - Sunday, 06 April 2008, 13:33 GMT
Last edited by Jan de Groot (JGC) - Thursday, 10 April 2008, 21:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
When I try to install gstreamer0.10-base pacman says:
error: gstreamer0.10-base not found in sync db

When I go directly to the mirror I use via a FTP client I see the package there.
But in /var/lib/pacman/sync/extra there's no trace of the pkg.
I have tried a different mirror and resync the package db, but with no effect.

Additional info:
* package version(s)
pacman 3.1.4-1 (x86_64)

* config and/or log files etc.
pacman.log says nothing except for: synchronizing package lists

Steps to reproduce:
pacman -S gstreamer0.10-base
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 10 April 2008, 21:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fixed in x86_64 by now:
[jan@server ~]$ pacman -Ss gstreamer0.10-base
extra/gstreamer0.10-base 0.10.19-1
GStreamer Multimedia Framework Base plugin libraries
extra/gstreamer0.10-base-plugins 0.10.19-1 (gstreamer0.10-plugins)
GStreamer Multimedia Framework Base Plugins (gst-plugins-base)
Comment by Ondřej Konečný (andrew9888) - Sunday, 06 April 2008, 13:37 GMT
Oh, I forgot. The system is a fresh install.
Comment by Ondřej Konečný (andrew9888) - Sunday, 06 April 2008, 14:19 GMT
I dowlnloaded the package from te server and installed manually. It runs fine but I would rather install it the standard way with pacman -S gstreamer0.10-base.
Comment by Filip Wojciechowski (fwojciec) - Sunday, 06 April 2008, 14:53 GMT
I can confirm this -- something seems to be wrong with the database for the extra repo. I can't install the package either.
Comment by adam (adamruss) - Sunday, 06 April 2008, 17:26 GMT
removing "testing" installing it and returning "testing" did the trick for me. for some reason the package in core is newer then the testing. i think this will be fixed fast
Comment by Filip Wojciechowski (fwojciec) - Sunday, 06 April 2008, 18:15 GMT
Hmmm, I don't see it in any of the repos - i.e. pacman -Ss ^gstreamer0.10-base$ (with testing enabled or disabled) returns no hits.
Comment by LB06 (LB06) - Sunday, 06 April 2008, 20:15 GMT
I can confirm it. It also occurs without testing (which I've never used or enabled so far).
Comment by Josh Valdez (ExxonValdeez) - Sunday, 06 April 2008, 20:36 GMT
Same problem here, there is a thread in the forums about it here: http://bbs.archlinux.org/viewtopic.php?id=46641
Comment by Piotr Beling (qwak) - Sunday, 06 April 2008, 21:30 GMT
I have the same problem. Tried few mirrors.
Comment by Piotr Beling (qwak) - Monday, 07 April 2008, 20:06 GMT Comment by Jorge López (panecillo) - Tuesday, 08 April 2008, 12:44 GMT
Same problem here.

qwak workaround worked only after installing glib2 and liboil manually.
Comment by Piotr Beling (qwak) - Tuesday, 08 April 2008, 12:57 GMT
...and maybe something more... but what's the problem Jorge?
pacman -U ftp://ftp.gigabit.nu/extra/os/x86_64/gstreamer0.10-base-0.10.19-1-x86_64.pkg.tar.gz
write what we need, and:
pacman -S any things what we need to install gstreamer0.10-base-0.10.19-1-x86_64.pkg.tar.gz
pacman -U ftp://ftp.gigabit.nu/extra/os/x86_64/gstreamer0.10-base-0.10.19-1-x86_64.pkg.tar.gz
pacman -Syu
Comment by Roman Kyrylych (Romashka) - Tuesday, 08 April 2008, 13:17 GMT
guys, we're in the process of doing some serious work on the server, so all CVS, database and package updates are frozen.
Thus something can be out of sync now and we cannot fix it. As soon as we finish the work everything will be in sync again.
Comment by Pierre-Adrien BUISSON (PierreAd) - Wednesday, 09 April 2008, 16:23 GMT
The fix worked for me, thanks a lot...!

Loading...