Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#10066 - eclipse freeze on code assist or create new workspace

Attached to Project: Arch Linux
Opened by Josh Kropf (jiggak) - Wednesday, 02 April 2008, 23:04 GMT
Last edited by Greg (dolby) - Tuesday, 24 June 2008, 10:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
Eclipse freezes when performing code assist (or accessing anything 'browser' related). Removing firefox (pacman -R firefox) seems to resolve the problem.

Additional info:
* eclipse 3.3.1 (extras package) or eclipse 3.3.2 from eclipse.org
* firefox 2.0.0.13-1
* jre 6u5-1

Steps to reproduce:
1. Create a new workspace
2. Eclipse freezes before new workspace is finished being created

OR

1. Open an existing workspace with a Java project.
2. Perform code assist (eg: type System. and hit <ctrl>+space)

OR

1. Open an existing workspace.
1. Open Window->Preferences
2. Go to General->Web Browser preference page
This task depends upon

Closed by  Greg (dolby)
Tuesday, 24 June 2008, 10:15 GMT
Reason for closing:  Fixed
Comment by Łukasz Fidosz (Luk4sz) - Thursday, 03 April 2008, 15:42 GMT
I confirming it. After I removed firefox everythink is ok.
Comment by David Rosenstrauch (darose) - Thursday, 03 April 2008, 19:25 GMT
Egads! There's got to be a better fix than uninstalling firefox, isn't there?!?!?
Comment by Josh Kropf (jiggak) - Thursday, 03 April 2008, 19:37 GMT
Yeah, you can just install the previous version of eclipse provided you haven't cleaned the package cache.
http://bbs.archlinux.org/viewtopic.php?id=46443
Comment by Josh Kropf (jiggak) - Thursday, 03 April 2008, 19:38 GMT
Sorry, I meant the previous version of 'firefox' (with this thing let you edit comments)
Comment by Li Sun (depp) - Thursday, 03 April 2008, 19:59 GMT
Ye, that's not the ideal resolution. But anyway I'm forced to use firefox3 from unstable instead.
Comment by David Rosenstrauch (darose) - Thursday, 03 April 2008, 20:03 GMT
right. that's what i did (downgraded to 2.0.0.12), and it did work. (thank god - i can get some work done!) but that's not really a long term solution, and there's got to be a better one.

anyone know the upstream cause? i googled on it, but wasn't able to find anything. i.e., is it an eclipse bug? a firefox bug?
Comment by Li Sun (depp) - Thursday, 03 April 2008, 20:14 GMT
Someone said even the removal of any firefox-lib entry from java.library.path doesn't solve the problem either.
Comment by Rene Dohan (innusius) - Friday, 04 April 2008, 15:41 GMT
for me downgrading xulrunner solved it
Comment by David Rosenstrauch (darose) - Friday, 04 April 2008, 16:16 GMT
@innusius: good find! I'll have to try that!

I assume, then, that the old xulrunner will not break the new firefox?
Comment by Rene Dohan (innusius) - Friday, 04 April 2008, 17:05 GMT
I am running firefox 2.0.0.13 and eclipse is working now
Comment by David Rosenstrauch (darose) - Friday, 04 April 2008, 17:13 GMT
Hmmm ... downgrading to xulrunner 1.8.1.12-1 didn't fix it for me. (Perhaps cause I'm pinned to an older version of Eclipse (3.2.2)).

Would love to figure out what's broken upstream with this. Maybe we need to file a bug on Firefox?
Comment by cas (parti) - Sunday, 06 April 2008, 22:03 GMT
same freeze issues here with eclipse 3.3.0 & 3.3.2; downgrading to xulrunner-1.8.1.12-1-i686 did it for me on both versions
Comment by Marco Praher (sofa5000) - Wednesday, 09 April 2008, 20:22 GMT
I have the same problem, but from where can I get xulrunner-1.8.1.12 when it's not in the package cache anymore?
Comment by Francesco Rubino (setsuna) - Thursday, 10 April 2008, 08:25 GMT
Eclipse freezes also when I run a J2EE project, after starting tomcat, just before displaying the internal web browser, removing xulrunner solved it, downgrading to 1.8.1.12 not.

I noticed that package swt depends on it (xulrunner), I tried to recompile it from abs, upgrading to the lastest version (3.3.1.1) but it didn't solve it. Inside the PKGBUILD I noticed some lines referring to mozilla/xulrunner libs, but I don't have the knowledge to intervene there (if there's an actual error or change to be made)
Comment by Florian (minus) - Tuesday, 15 April 2008, 18:46 GMT
I have problems with eclipse, too. With my old workspace it started, but it freezes after a few seconds and when closing it by hand, the eclipse process does not terminate.

Now i deinstalled, removed ~/.eclipse, installed again and choose another workspace, but eclipse doesn't work anymore. It freezes while showing the bootsplash. The only way i can start it is via jdb. When i close eclipse then the java process does not terminate.

I also tried removing firefox, but no changes.
Comment by Ionut Biru (wonder) - Thursday, 17 April 2008, 17:10 GMT
eclipse doesn't run because of eclipse-cdt. don't know why he doesn't run from gnome menu but when i run it from terminal it's working
Comment by Ionut Biru (wonder) - Thursday, 17 April 2008, 17:24 GMT
i was wrong. on the other pc eclipse won't run if even if i don't have any plugin
Comment by David Rosenstrauch (darose) - Friday, 18 April 2008, 15:52 GMT
Firefox has now upgraded to 2.0.0.14, which also experiences this problem, and I still have no workable solution other than downgrading to FF 2.0.0.12.

So I've opened Eclipse bug #227792 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=227792) for this problem.
Comment by Francesco Rubino (setsuna) - Saturday, 19 April 2008, 09:43 GMT
Now I'm using firefox3b5, and eclipse freezes as always when using code assist or accessing the web browser configuration in a Java or Java EE perspective

Code assist DOESN'T freezes when using a pydev perspective, but still freezes when accessing web browser preferences

I've tried all the other options, but only removing xulrunner prevents eclipse from freezing
Comment by Marco Praher (sofa5000) - Saturday, 19 April 2008, 09:49 GMT
Starting Eclipse this way works for me:

export LD_LIBRARY_PATH=/opt/java/jre/lib/i386/client::/opt/java/jre/lib/i386
/opt/eclipse/eclipse
Comment by Francesco Rubino (setsuna) - Saturday, 19 April 2008, 09:54 GMT
tried that too, it doesn't work.

Besides, you aren't using a version from the repositories, right? It should be located in /usr/share/eclipse, at least mine is there.
Comment by Marco Praher (sofa5000) - Saturday, 19 April 2008, 10:04 GMT
You are right, I have downloaded Eclipse from eclipse.org, because I need some different versions of Eclipse parallel and the package from extra is outdated. Maybe you like to try it with the newest version of Eclipse (3.3.2).
Comment by Francesco Rubino (setsuna) - Saturday, 19 April 2008, 10:11 GMT
I've compiled it (3.3.2) from the original PKGBUILD when the issue arised.

I have found my solution: commenting /usr/lib/xulrunner in /etc/ld.conf and running ldconfig (as root)

I remember adding /usr/lib/xulrunner to ld.conf because the wikipedia plugin of gmpc-git couldn't find libgtkembedmoz.so so I added it.

Maybe it works for others too.
Comment by Petr Adamec (funny) - Wednesday, 23 April 2008, 11:43 GMT
I have the same problem. But solution form this page doesnt resolve my problem.
I have no firefox and I never have had it.
I dont know how resolve this problem. I have no time for it. I have to works on my program.
Comment by Rene Dohan (innusius) - Wednesday, 23 April 2008, 12:27 GMT
Petr: search for xulrunner maybe you don't have to have firefox and have xulrunner installed , it seems xulrunner is casing problem , maj sa :)
Comment by David Rosenstrauch (darose) - Thursday, 24 April 2008, 14:40 GMT
Hmmm .... nothing here seems to solve the problem.

I'll follow up on the bug upstream at https://bugs.eclipse.org/bugs/show_bug.cgi?id=227792.
Comment by Francesco Rubino (setsuna) - Wednesday, 30 April 2008, 18:24 GMT
My previous solution isn't working in fact, it seems that xulrunner wasn't installed.

I can confirm that removing it (xulrunner) is my only solution.
Comment by adam (adamruss) - Wednesday, 07 May 2008, 03:47 GMT
i have a very funny solution for me, i cant explain this -

if i run "/usr/share/eclipse/eclipse" it freezes on "ctrl+space"
but if i just type "eclipse" (from terminal / alt+f2 etc..) it works fine!
this is very strange, i changed "/usr/share/eclipse/eclipse" to "eclipse" on the menu icon and now everything works fine.

also i have this on my ~/.bashrc but i'm not sure it's related:

export PATH=/opt/java/bin:$PATH;
export JAVA_HOME="/opt/java";
export LIBXCB_ALLOW_SLOPPY_LOCK=true
Comment by adam (adamruss) - Wednesday, 07 May 2008, 03:52 GMT
and of course i recommend using this ugly hack to fix the xcb bug with java:

sed -i 's/XINERAMA/FAKEEXTN/g' /opt/java/jre/lib/i386/xawt/libmawt.so
Comment by adam (adamruss) - Wednesday, 07 May 2008, 04:12 GMT
export LD_LIBRARY_PATH=/opt/java/jre/lib/i386/client::/opt/java/jre/lib/i386

also does the trick
Comment by Avelino de Almeida Bego (avelinobego) - Wednesday, 11 June 2008, 04:04 GMT
To fix this problem, proceed as follows:

1) pacman -S extra/xulrunner
2) Edit /etc/ld.so.conf, and put this line: /usr/lib/xulrunner-1.8.1.14 (in my case, version is 1.8.1.14)
3) Run ldconfig


This gives the eclipse find the library libxul.so
Comment by Rene Dohan (innusius) - Wednesday, 11 June 2008, 07:18 GMT
xulrunner 1.8.1.14-2 resolved issue for me , sia , unsubscribing...
Comment by David Rosenstrauch (darose) - Monday, 23 June 2008, 14:32 GMT
Although this problem seemed to be solved for other ppl, I was actually still experiencing it, and none of the solutions here seemed to work.

However, after upgrading to FF3.0 (and/or perhaps the xulrunner update as well) this now seems to be fixed. (w00t!)

Can anyone else confirm?
Comment by David Rosenstrauch (darose) - Monday, 23 June 2008, 21:03 GMT
If someone else can confirm this, we can probably close it.
Comment by Tiago Pierezan Camargo (tcamargo) - Tuesday, 24 June 2008, 09:04 GMT
It's working well here. In fact, it was working fine for some time. Confirmed!

Loading...