Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65564 - [kmod] 27-1 causes "cp: cannot stat '(builtin)': No such file or directory" during mkinitcpio

Attached to Project: Arch Linux
Opened by Pascal E. (hardfalcon) - Thursday, 20 February 2020, 08:30 GMT
Last edited by Dave Reisner (falconindy) - Friday, 20 March 2020, 17:53 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dave Reisner (falconindy)
Giancarlo Razzolini (grazzolini)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

kmod 27-1 causes the error message "cp: cannot stat '(builtin)': No such file or directory" when building the fallback initramfs during mkinitcpio runs. To be more precise, the error seems to occur after the last initcpio hook is run. The non-fallback initramfs seems to build just fine, and downgrading to kmod 26-3 makes the error go away.
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 20 March 2020, 17:53 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#65725
Comment by Giancarlo Razzolini (grazzolini) - Thursday, 20 February 2020, 14:34 GMT
We have a PR for this already. I'm going to test it today and see if I patch mkinitcpio with it. https://github.com/archlinux/mkinitcpio/pull/17
Comment by Pascal E. (hardfalcon) - Friday, 21 February 2020, 15:31 GMT
Thanks, I've tested the patch, and it seems to work fine for me without any issues so far. :-)
Comment by Giancarlo Razzolini (grazzolini) - Friday, 21 February 2020, 16:49 GMT
I expect to land a patched version of mkinitcpio either today or this weekend. kmod won't be moved in the meantime.
Comment by Giancarlo Razzolini (grazzolini) - Friday, 21 February 2020, 17:23 GMT
But, one thing I forgot to make clear, this issue doesn't prevent the creation of the fallback image at all, it's a harmless error.
Comment by Jeff Hodd (jghodd) - Friday, 20 March 2020, 16:18 GMT
  • Field changed: Percent Complete (100% → 0%)
Bug still present in mkinitcpio-27-3:

==> Starting build: 5.5.8-arch1-1.0
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [915resolution]
-> Running build hook: [v86d]
-> Running build hook: [memdisk]
-> Running build hook: [archiso_shutdown]
-> Running build hook: [archiso_bslx]
-> Running build hook: [archiso_loop_mnt]
-> Running build hook: [archiso_pxe_common]
==> WARNING: Possibly missing firmware for module: lantiq_gswip
-> Running build hook: [archiso_pxe_nbd]
-> Running build hook: [archiso_pxe_http]
-> Running build hook: [archiso_pxe_nfs]
-> Running build hook: [archiso_kms]
-> Running build hook: [block]
-> Running build hook: [pcmcia]
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [gma3600]
-> Running build hook: [bslx_live_desktop]
cp: cannot stat '(builtin)': No such file or directory
==> Generating module dependencies
==> Creating xz-compressed initcpio image: /boot/archiso.img
==> WARNING: errors were encountered during the build. The image may not be complete.

# pacman -Qs mkinitcpio
local/mkinitcpio 27-3.0
Modular initramfs image creation utility


@Giancarlo

Yes, this is being run from within archiso

@Doug

It is arch. I'm building an arch32 iso.
Comment by Giancarlo Razzolini (grazzolini) - Friday, 20 March 2020, 16:22 GMT
@Jeff

Are you running this from within the arch iso?
Comment by Doug Newgard (Scimmia) - Friday, 20 March 2020, 16:29 GMT
27-3.0 and 5.5.8-arch1-1.0, they're not on Arch.
Comment by Jeff Hodd (jghodd) - Friday, 20 March 2020, 17:52 GMT
  • Field changed: Percent Complete (100% → 0%)
@Giancarlo - yes, am running from an archiso environment

@Doug - it is arch. i'm building an arch32 iso

currently running mkinitcpio-27-3 with kmod-27-1.1. if i downgrade kmod to 26-3, the problem goes away.
Comment by Dave Reisner (falconindy) - Friday, 20 March 2020, 17:53 GMT
mkinitcpio 27-3 does *not* fix this. This is, however, a dupe of FS#65725.

Loading...