Community Packages

User added to notification list.
Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#54246 - [vagrant] Version 1.9.5 cannot install plugins anymore

Attached to Project: Community Packages
Opened by Julien M'Poy (groovytron) - Wednesday, 31 May 2017, 21:27 GMT
Last edited by Jonathan Steel (jsteel) - Saturday, 15 July 2017, 20:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Steel (jsteel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Vagrant 1.9.5 actually can't install plugins.

To reproduce the problem:

1. Simply install the package or upgrade it with "pacman -Syu".
2. Try to install a plugin with "vagrant plugin install <plugin-name>".

Trying to downgrade with AUR's downgrader package doesn't fix the problem.

An issue has been opened on GitHub and details such as debug output can be found here:https://github.com/mitchellh/vagrant/issues/8635

Thank you for you help.
This task depends upon

Closed by  Jonathan Steel (jsteel)
Saturday, 15 July 2017, 20:24 GMT
Reason for closing:  Fixed
Comment by Jonathan Steel (jsteel) - Sunday, 04 June 2017, 10:01 GMT
I'll try and work out at what point this broke. It doesn't look like an upstream commit that caused the issue.
Comment by Jonathan Steel (jsteel) - Sunday, 04 June 2017, 17:17 GMT
Looks like the issue is when building with boost-libs-1.64.0-1. Maybe upstream can test against boost 1.64 and confirm if it works for them. I'll update the upstream bug report.
Comment by Jacob Karlsson (Powersource) - Friday, 07 July 2017, 08:29 GMT
Comment by Jonathan Steel (jsteel) - Monday, 10 July 2017, 20:36 GMT
I've patched the embedded (vagrant-substrate) ruby 2.3 to build with gcc 7 and it looks OK now. Ideally upstream would get it working with the latest/stable versions but seeing as they've gone quiet I'll apply this workaround to the Arch package for the time being.

Please try vagrant-1.9.7-1 and vagrant-substrate-718.205e64c-1 and report any issues here.
Comment by Massimiliano Torromeo (mtorromeo) - Tuesday, 11 July 2017, 08:02 GMT
There are other issues now. When I try compiling vagrant plugins I get some errors like this one:

"gcc -E -I/opt/vagrant/embedded/include/ruby-2.3.0/x86_64-linux -I/opt/vagrant/embedded/include/ruby-2.3.0/ruby/backward -I/opt/vagrant/embedded/include/ruby-2.3.0 -I. -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include/libxml2 -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include/libxml2 -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include/libxml2 -D_FORTIFY_SOURCE=2 -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include -O2 -I/build/vagrant-substrate/src/vagrant-installers/opt/vagrant/embedded/include -I/build/vagrant-substrate/src/vagrant-installers/vagrant-substrate/cache/ruby-2.3.4/include -fPIC -g -DXP_UNIX -Wall -Wcast-qual -Wwrite-strings -Wconversion -Wmissing-noreturn -Winline conftest.c -o conftest.i"
conftest.c:3:10: fatal error: libxml/xmlversion.h: File o directory non esistente

As you can see there are a lot of include paths prefixed with "/build/vagrant-substrate/src/vagrant-installers/" (the chroot directory).
These issues are a consequence of the incorrect pkg-config files in /opt/vagrant/embedded/lib/pkgconfig.

I was able to build the plugin successfully after patching the pkg-config files with:
sudo sed 's@/build/vagrant-substrate/src/vagrant-installers/@/@g' -i /opt/vagrant/embedded/lib/pkgconfig/*.pc
Comment by Jonathan Steel (jsteel) - Tuesday, 11 July 2017, 08:22 GMT
OK thanks for reporting that and for the workaround. I'll add that sed to the end of the PKGBUILD for now and look into this further (talk to upstream) to see if we can come up with a fix earlier in the build process.

Loading...