Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#40807 - [firefox] [totem] gst-vaapi crashes

Attached to Project: Arch Linux
Opened by alex (kabolt) - Wednesday, 11 June 2014, 20:57 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 15 December 2015, 19:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Evangelos Foutras (foutrelis)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 31
Private No

Details

Description:
if you use gst-libav for displaying html5 videos and have gst-vaapi installed without having vaapi support
firefox segfaults with the error message:
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/r600_drv_video.so
libva info: va_openDriver() returns -1
Speicherzugriffsfehler (Speicherabzug geschrieben)

Bugfix: remove gst-vaapi
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 15 December 2015, 19:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  Firefox 43 now uses FFmpeg for H264 decoding so this can be considered fixed.
Comment by Evangelos Foutras (foutrelis) - Thursday, 12 June 2014, 02:54 GMT Comment by Antonio (kokoko3k) - Thursday, 12 June 2014, 15:49 GMT
Mmh, i use vaapi-vdpau wrapper through libva-vdpau-driver and for me
libva info: va_openDriver() returns 0
Still, my Firefox crashed:
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0
Comment by cristHian Gz. (gcca) - Thursday, 12 June 2014, 19:51 GMT
I have installed libvdpau-va-gl and libva-vdpau-driver.
Now, i use Nvidia driver. When i have nouveau, firefox crahsed sometimes.
To work with nouveau, i created a link "/usr/lib/dri/nouveau_drv_video.so" to "/usr/lib/dri/vdpau_drv_video.so".


libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/dri/vdpau_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0

** (firefox:27682): CRITICAL **: gst_vaapi_image_get_plane: assertion '_gst_vaapi_image_is_mapped(image)' failed

** (firefox:27682): CRITICAL **: gst_vaapi_image_get_pitch: assertion '_gst_vaapi_image_is_mapped(image)' failed

** (firefox:27682): CRITICAL **: gst_vaapi_image_get_plane: assertion '_gst_vaapi_image_is_mapped(image)' failed

** (firefox:27682): CRITICAL **: gst_vaapi_image_get_pitch: assertion '_gst_vaapi_image_is_mapped(image)' failed

“firefox ” terminated by signal SIGSEGV (Address boundary error)
Comment by A. Bosch (progandy) - Thursday, 12 June 2014, 20:58 GMT
I can confirm that bug and have some additional data. I explicitely set LIBVA_DRIVER_NAME=_NONE_, since a missing va driver should result in a non-accelerated pipeline. Still, firefox crashes. Either firefox or gstreamer is unable to use a fallback pipeline if gst-vaapi is installed, but without a working driver.


% LIBVA_DRIVER_NAME=_NONE_ firefox --no-remote -p test

(process:12116): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: User requested driver '_NONE_'
libva info: Trying to open /usr/lib/dri/_NONE__drv_video.so
libva info: va_openDriver() returns -1
[12178] ###!!! ABORT: Aborting on channel error.: file /build/firefox/src/mozilla-release/ipc/glue/MessageChannel.cpp, line 1522
[12178] ###!!! ABORT: Aborting on channel error.: file /build/firefox/src/mozilla-release/ipc/glue/MessageChannel.cpp, line 1522
[1] 12116 segmentation fault (core dumped) LIBVA_DRIVER_NAME=_NONE_ firefox --no-remote -p test
Comment by Pedro Nariyoshi (nariox) - Sunday, 15 June 2014, 13:50 GMT
This was also reported upstream here: https://bugzilla.mozilla.org/show_bug.cgi?id=1024125
Comment by Doug Newgard (Scimmia) - Friday, 20 June 2014, 15:02 GMT
Anyone that's getting this, can you take a look at  FS#40914 ? See if a patched libva makes a difference here?
Comment by ValdikSS (ValdikSS) - Friday, 20 June 2014, 15:09 GMT
Can confirm. Patch for libva fixed the issue.
Comment by Kaan Kasım (Kaan) - Saturday, 21 June 2014, 15:59 GMT
  • Field changed: Percent Complete (100% → 0%)
Still having segfaults, my crash log is exactly like the cristHian's. Vaapi normally works with vlc it's just gstreamer apps that crashes, parole too.
Comment by Doug Newgard (Scimmia) - Saturday, 21 June 2014, 16:01 GMT
Kaan, this is with libva 1.3.1-2?
Comment by Kaan Kasım (Kaan) - Saturday, 21 June 2014, 16:07 GMT
Yes. Here is vainfo output and firefox, parole has the same crash log too. Both vaapi and vdpau works fine with vlc.

http://pastie.org/9311788
Comment by boot (boot) - Saturday, 21 June 2014, 17:31 GMT
I have the same issue.

[New Thread 0x7fff97c9d700 (LWP 448)]
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: User requested driver 'vdpau'
libva info: Trying to open /usr/lib/dri/vdpau_drv_video.so
libva info: Found init function __vaDriverInit_0_33
[New Thread 0x7fff92ab1700 (LWP 449)]
libva info: va_openDriver() returns 0
[New Thread 0x7fff91a6d700 (LWP 458)]
[New Thread 0x7fff90a35700 (LWP 459)]
[New Thread 0x7fff90234700 (LWP 460)]

** (firefox:32735): CRITICAL **: gst_vaapi_image_get_plane: assertion '_gst_vaapi_image_is_mapped(image)' failed

** (firefox:32735): CRITICAL **: gst_vaapi_image_get_pitch: assertion '_gst_vaapi_image_is_mapped(image)' failed

** (firefox:32735): CRITICAL **: gst_vaapi_image_get_plane: assertion '_gst_vaapi_image_is_mapped(image)' failed

** (firefox:32735): CRITICAL **: gst_vaapi_image_get_pitch: assertion '_gst_vaapi_image_is_mapped(image)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff91a6d700 (LWP 458)]
0x00007fffc6c7d380 in ?? ()
(gdb) bt
#0 0x00007fffc6c7d380 in ?? ()
#1 0x00007fff9cc91a65 in ?? () from /usr/lib/libgstvideo-1.0.so.0
#2 0x00007fff9cc740ad in ?? () from /usr/lib/libgstvideo-1.0.so.0
#3 0x00007fff91c8cbfb in ?? () from /usr/lib/gstreamer-1.0/libgstvideoconvert.so
#4 0x00007fff91c8b8a9 in ?? () from /usr/lib/gstreamer-1.0/libgstvideoconvert.so
#5 0x00007fff9cc7a777 in ?? () from /usr/lib/libgstvideo-1.0.so.0
#6 0x00007fff9cedb847 in ?? () from /usr/lib/libgstbase-1.0.so.0
#7 0x00007fff9cedc0a1 in ?? () from /usr/lib/libgstbase-1.0.so.0
#8 0x00007fff9e75cd08 in ?? () from /usr/lib/libgstreamer-1.0.so.0
#9 0x00007fff9e74ee2b in gst_proxy_pad_chain_default () from /usr/lib/libgstreamer-1.0.so.0
#10 0x00007fff9e75cd08 in ?? () from /usr/lib/libgstreamer-1.0.so.0
#11 0x00007fff99f35eb0 in ?? () from /usr/lib/gstreamer-1.0/libgstcoreelements.so
#12 0x00007fff9e78a549 in ?? () from /usr/lib/libgstreamer-1.0.so.0
#13 0x00007fffef44d61c in ?? () from /usr/lib/libglib-2.0.so.0
#14 0x00007fffef44cc95 in ?? () from /usr/lib/libglib-2.0.so.0
#15 0x00007ffff7bc5124 in start_thread () from /usr/lib/libpthread.so.0
#16 0x00007ffff70e24bd in clone () from /usr/lib/libc.so.6
Comment by patrick (potomac) - Saturday, 21 June 2014, 17:33 GMT
I confirme the bug, the patch doesn't fix the problem, I use the last version of libva package ( 1.3.1-2 )

I get the same output than cristHian Gz,

I have an amd radeon HD4650 and I use the open source driver ( radeon ),

vdpau driver works fine with mplayer,

I think the culprit is libva, because I have problems in kaffeine ( dvb-t software ) if I use libva for hardware acceleration ( mpeg2 video will freeze ), if I use vdpau then there is no problem with kaffeine
Comment by Kaan Kasım (Kaan) - Saturday, 21 June 2014, 18:49 GMT
I wonder if it's libva or gst-vaapi that is the problem? Because vaapi works on my nvidia card on vlc and other software that don't rely on gst.
Comment by patrick (potomac) - Saturday, 21 June 2014, 20:01 GMT
I notice bugs in vlc 2.1.4-2 with vaapi on mpeg2 files ( corrupt display, bad frames ) and kaffeine doesn't work with vaapi,

maybe these problems occur only with the radeon open source driver

Comment by Conor (conorbev) - Sunday, 22 June 2014, 08:29 GMT
I can report the same issue. In addition, I have another way to repliacate it using totem rather than firefox. The steps are:

Open video in Totem, it starts to play fine.
Try to load a subtitle file. It crashes.

Per the original report removing gst-vaapi makes the issue go away (at the expense of not having graphics hardware accelerated video decoding of course).
Comment by Kisame (Kisame217) - Saturday, 05 July 2014, 20:58 GMT
In my case, firefox does't crash but the video is not rendered i.e audio is fine but video remains stuck at first frame with high cpu usage.
Removing gst-vaapi fixes the issue with firefox.

Interestingly, I get this output in terminal when using gst-vaapi with both firefox and gst-play-1.0

libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0

Hardware:Intel Core i5 with HD3000 graphics.

While gst-play-1.0 plays the video without hitch, firefox increases cpu usage to 80-90%.
Comment by Alexandre Bique (babali) - Sunday, 06 July 2014, 16:52 GMT
Is Archlinux the only distro to have this issue?
I'm getting crazy with these crashes :D
Comment by Jan Steffens (heftig) - Sunday, 06 July 2014, 16:53 GMT
Just get rid of gst-vaapi if it's a problem. It's not ready for prime-time just yet.
Comment by mattia (nTia89) - Monday, 21 July 2014, 14:35 GMT
I don't know if it's exactly the same bug, but visiting gmail.com , ONLY after that firefox completes to load the inbox page, firefox crashes.
In the terminal I get:

[mattia@arch-dekstop ~]$ firefox

(process:10270): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:10270): GStreamer-CRITICAL **: gst_bin_get_by_name: assertion 'GST_IS_BIN (bin)' failed

(firefox:10270): GStreamer-CRITICAL **: gst_bin_get_by_name: assertion 'GST_IS_BIN (bin)' failed

(firefox:10270): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

** (firefox:10270): CRITICAL **: gst_app_sink_set_callbacks: assertion 'GST_IS_APP_SINK (appsink)' failed

** (firefox:10270): CRITICAL **: gst_app_sink_set_callbacks: assertion 'GST_IS_APP_SINK (appsink)' failed

(firefox:10270): GStreamer-CRITICAL **: gst_element_get_static_pad: assertion 'GST_IS_ELEMENT (element)' failed

(firefox:10270): GStreamer-CRITICAL **: gst_pad_add_probe: assertion 'GST_IS_PAD (pad)' failed

(firefox:10270): GStreamer-CRITICAL **: gst_pad_add_probe: assertion 'GST_IS_PAD (pad)' failed
Segmentation fault

but nothing in dmesg
Comment by boot (boot) - Monday, 28 July 2014, 12:52 GMT
Latest gstreamer packages (released yesterday) fixed my Firefox issue.
Comment by Antonio (kokoko3k) - Monday, 28 July 2014, 14:25 GMT
Not mine, with nvidia and libva-vdpau-driver.
This works for me in SD, http://www.youtube.com/watch?v=9vZvqNBGagw
but crashes firefox As soon as i switch it to hd.
ibva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0
Comment by mattia (nTia89) - Monday, 28 July 2014, 15:27 GMT
as far as I'm concerned, sites which previously gave me pain, now work e.g.: gmail's inbox
youtube has always worked well for me
the above youtube video works, too, both SD and HD, both window and full-screen

EDIT:

I report the output, could be useful:
[mattia@arch-dekstop ~]$ firefox

(process:4379): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

** (firefox:4379): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

** (firefox:4379): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

** (firefox:4379): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

** (firefox:4379): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

** (firefox:4379): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed
ATTENTION: default value of option force_s3tc_enable overridden by environment.
ATTENTION: option value of option force_s3tc_enable ignored.
Comment by Antonio (kokoko3k) - Monday, 28 July 2014, 16:27 GMT
Are you on opensource drivers? (vaapi-native)
My issue is probably is due to libva-vdpau-driver (?)
Comment by mattia (nTia89) - Monday, 28 July 2014, 17:02 GMT
yes, I use xf86-video-nouveau open-source driver
but anyway I have libva-vdpau-driver installed, too
Comment by Kaan Kasım (Kaan) - Tuesday, 29 July 2014, 01:24 GMT
same config as Antonio, sd videos fine while hd ones cause a seg fault.
Comment by Conor (conorbev) - Monday, 11 August 2014, 14:12 GMT
Latest gstreamer packages seem to fix firefox for me, but, I can no longer play any videos (at least with the sampling of codecs that I've tried) in totem with gst-vaapi installed. It just pops up "GStreamer encountered a general stream error" when you try to play the file.
Comment by mattia (nTia89) - Monday, 11 August 2014, 16:10 GMT
I got the same error prior the upgrade.

now everything works: both with totem and parole (another media player based on gst)

EDIT: with parole I get those warning (because the player works and the video is played...):

libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
Comment by Conor (conorbev) - Monday, 11 August 2014, 16:27 GMT
Interesting Mattia. I'd never tried parole but I just gave it a go and it works for me.

Could you try playing http://samples.mplayerhq.hu.nyud.net/V-codecs/h264/PAFF/Grey.ts with Totem? It's an example of file that plays in parole for me but not totem.
Comment by mattia (nTia89) - Monday, 11 August 2014, 16:33 GMT
yes, I could try , but the link doesn't work
Comment by Conor (conorbev) - Monday, 11 August 2014, 16:35 GMT Comment by Kaan Kasım (Kaan) - Monday, 11 August 2014, 16:39 GMT
Some videos do play now but some do not. I have no idea why some videos work while others give the same seg fault error(seems to be only hd, but not all), and youtube seems to cause seg fault on every video while using hd.
Comment by Conor (conorbev) - Monday, 11 August 2014, 16:48 GMT
Kaan: Can you give an example of a HD youtube video that causes a crash for you? I just tried a random one and it worked. I haven't seen any firefox crash since the update. I appear to only have issues with totem now - and even then the symptoms are different from before. The file doesn't play at all rather than it causes a segfault.
Comment by mattia (nTia89) - Monday, 11 August 2014, 16:49 GMT
@Conor: with parole I can't play the video because parole says:

Additional software is required.
Parole needs H.264 decoder to play this file.
It can be installed automatically.

anyway I already have libx264...

with totem, it can't play the video in fact I get a similar error, BUT totem plays sound:

No accelerated IMDCT transform found
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
** Message: Missing plugin: gstreamer|1.0|totem|H.264 decoder|decoder-video/x-h264, stream-format=(string)byte-stream, alignment=(string)nal, parsed=(boolean)true (H.264 decoder)
** Message: Automatic missing codec installation not supported (helper script missing)
Comment by Kaan Kasım (Kaan) - Monday, 11 August 2014, 16:52 GMT
@Conor: I should have mentioned that I was using nvidia drivers, maybe that's the difference.
About the videos, I just opened random ones and while sd were fine switching them to hd doesn't work. Weird thing is an episode of a hd tv show I had didn't work, same error, while all the other episodes did.
Comment by Conor (conorbev) - Monday, 11 August 2014, 16:53 GMT
mattia: I belive it's gst-plugins-ugly that gives the codec for H264 (though I do see libx264 is one of its deps.. so not really sure it doesn't work for you already).

Anyway, with gst-plugins-ugly installed parole plays that file just fine for me, but totem does not. Wonder if totem just has issues with H264?
Comment by mattia (nTia89) - Monday, 11 August 2014, 16:54 GMT
do you get the same output in the terminal with totem?
Comment by Conor (conorbev) - Monday, 11 August 2014, 16:56 GMT
Kaan: Odd, I am using nvidia drivers also.. I just tried this video for example: https://www.youtube.com/watch?v=P5_GlAOCHyE Though for some reason it's only letting me select 720p rather than 1080p. Maybe it'd segfault if 1080p was an option ;-)
Comment by Kaan Kasım (Kaan) - Monday, 11 August 2014, 17:00 GMT
Hmm, I'll do more testing later. I'm using nightly which doesn't have gst 1 enabled for some reason and it doesn't use 0.10 vaapi. Anyway, which firefox version do you use?
Comment by Conor (conorbev) - Monday, 11 August 2014, 17:09 GMT
Kaan: firefox, 31.0-1. Actually, I do see the same thing as you though. I was mistaken :( I have been playing around removing and re-installing gst-vaapi. It appears I hadn't restarted firefox since I last re-installed gst-vaapi and indeed it does segfault on that HD youtube video now that I have done so. It can't have been using vaapi before. So.. some improvement was made but yeah, it seems this bug is still around unfortuantely.

Mattia: I get different output from you in the terminal when playing Grey.ts with totem. Though it's to be expected as we're using different graphics drivers and I have whatever codec pack gstreamer needs to play that file installed (I think gst-plugins-ugly). In both totem and parole I get the same output in the terminal, except in Parole the video plays and in totem it doesn't. The file plays fine in totem if I remove gst-vaapi. It is:

No accelerated IMDCT transform found
libva info: VA-API version 0.35.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0
Comment by Antonio (kokoko3k) - Monday, 02 March 2015, 17:22 GMT
  • Field changed: Percent Complete (100% → 0%)
firefox still crashes to me as soon as i try to seek in this video https://www.youtube.com/watch?v=9vZvqNBGagw while watching it in 720p.

libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
Errore di segmentazione
Comment by hamelg (hamelg) - Monday, 02 March 2015, 17:40 GMT
I get another error :

libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_37
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[2619] ###!!! ABORT: Divide by zero: file /build/firefox/src/mozilla-release/toolkit/xre/nsSigHandlers.cpp, line 154

Comment by Leonardo Andrés Gallego (sud_crow) - Saturday, 30 May 2015, 21:11 GMT
Hi everyone,

I'm having the same issue for a few days now. Took me a while to get the time to track it down.

After disabling everything (including hardware acceleration in settings), trying safe mode, and what not, I started noticing this in the console log:

[code]
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
Segmentation fault (core dumped)
[/code]

My hardware:
Intel i3
nvidia GTX 560

My driver setup and libraries are current:

[code]
local/lib32-libcl 1.1-1
OpenCL library and ICD loader from NVIDIA (32-bit)
local/lib32-libvdpau 1.1-1
Nvidia VDPAU library
local/lib32-nvidia-libgl 352.09-1
NVIDIA drivers libraries symlinks (32-bit)
local/lib32-nvidia-utils 352.09-1
NVIDIA drivers utilities (32-bit)
local/lib32-opencl-nvidia 352.09-1
OpenCL implemention for NVIDIA (32-bit)
local/libcl 1.1-4
OpenCL library and ICD loader from NVIDIA
local/libvdpau 1.1-1
Nvidia VDPAU library
local/nvidia 352.09-1
NVIDIA drivers for linux
local/nvidia-libgl 352.09-1
NVIDIA drivers libraries symlinks
local/nvidia-utils 352.09-1
NVIDIA drivers utilities
local/opencl-nvidia 352.09-1
OpenCL implemention for NVIDIA
local/xf86-video-nouveau 1.0.11-3 (xorg-drivers xorg)
Open Source 2D acceleration driver for nVidia cards
local/libva 1.5.1-1
Video Acceleration (VA) API for Linux
local/gstreamer-vaapi 0.5.10-1
GStreamer Multimedia Framework VA Plugins
[/code]


I found this post related to the same issue:
https://bbs.archlinux.org/viewtopic.php?id=182754

Which lead me to this bug report.

Here are the tests I did and what I found:

If I uninstall libva-vdpau-driver but keep gst-libav and gstreamer-vaapi, I get the following output from firefox:

[code]
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[/code]

And it doesn't seem to crash yet.

If, instead I uninstall gst-libav-1.4.5-1 and gstreamer-vaapi-0.5.10-1 , but keep libva-vdpau-driver-0.7.4-2, then I don t get any output from firefox about loading nvidia drivers when playing video (which means there is no acceleration), but no crashes either.

So, I don't know where the problem is, but it's in some way related to nvidia acceleration of html5 videos in firefox and this 3 packages.

My 100% working test (where I can reproduce while making changes) is this article from Rolling Stone:
http://www.rollingstone.com/music/videos/watch-coldplay-adapt-game-of-thrones-into-ridiculous-musical-20150522

If I click the fullscreen button in the video, it crashes. I didn't notice it's when it goes HD until I read the other reports in this bug.

ps. Tried the other videos posted. Same results.



Comment by hamelg (hamelg) - Sunday, 05 July 2015, 12:14 GMT
I gave it a try today.
Now, it works fine, no more crashes !
I do not know when it was fixed, nor what ?
Comment by Antonio (kokoko3k) - Monday, 06 July 2015, 08:01 GMT
It still crashes for me when going fullscreen or changing stream resolution or closing the tab/change url me with a completely updatd system..
Comment by Evangelos Foutras (foutrelis) - Saturday, 03 October 2015, 22:00 GMT
Is this still an issue with gstreamer-vaapi>=0.6.0?
Comment by Kevin Cox (kevincox) - Sunday, 04 October 2015, 18:58 GMT
I haven't had this happen in a long while. Seems fixed to me.
Comment by Antonio (kokoko3k) - Monday, 05 October 2015, 06:01 GMT
It still crashes here with firefox 41, 42 seems fine.
Comment by Mister Ypsilon (mrypsilon) - Tuesday, 03 November 2015, 16:41 GMT
firefox-beta-bin from AUR didn't crash for me, but after I changed to release 42 from official extra repo today, the crashes appeared again. Thougt it could be a packaging issue first, but when I switched back to the AUR version, the crashes continued. Seems to be an upstream issue that doesn't affect the betas...

Edit:
Sorry, I made a mistake, firefox-beta-bin 42.0-1 from AUR does NOT crash even though it is the same version as the firefox package in the official extra repository. So it seems like it is some packaging issue. Also, Media Source Extensions with WebM don't work with the official package while they do work with the AUR package.
Comment by Jan Steffens (heftig) - Tuesday, 03 November 2015, 16:58 GMT
Upstream builds use gstreamer 0.10, for which we have no vaapi support.

Loading...