Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34976 - [gedit] 3.8 plugins: Python loader broken

Attached to Project: Arch Linux
Opened by plasmoid (plasmoid) - Friday, 26 April 2013, 21:46 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 30 April 2013, 10:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Python2 plugins are not functional for Gedit 3.8

Additional info:
* package version(s)
gedit 3.8.1-1
libpeas 1.8.0-2

* config and/or log files etc.
>gedit -s
(gedit:24956): libpeas-WARNING **: Could not find loader 'python' for plugin 'projects'

> pacman -Ql libpeas |grep loader
libpeas /usr/lib/libpeas-1.0/loaders/
libpeas /usr/lib/libpeas-1.0/loaders/libgjsloader.so
libpeas /usr/lib/libpeas-1.0/loaders/libpython3loader.so
libpeas /usr/lib/libpeas-1.0/loaders/libpythonloader.so
libpeas /usr/lib/libpeas-1.0/loaders/libseedloader.so


Steps to reproduce: Start Gedit 3.8 and activate any python2 plugin such as Rgedit, RabbitVCS, gedit-latex, schemer (all in AUR)...


This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 30 April 2013, 10:53 GMT
Reason for closing:  Not a bug
Comment by Joschka Thurner (jthurner) - Monday, 29 April 2013, 12:58 GMT
Gedit 3.8 uses python 3 for its plugins. The bug is with the plugins, which have to support python3 / gedit 3.8, not with gedit.
e.g.
https://code.google.com/p/rabbitvcs/issues/detail?id=797
https://github.com/Quixotix/gedit-source-code-browser/pull/22
Comment by Jan Alexander Steffens (heftig) - Monday, 29 April 2013, 17:56 GMT
Well, technically libpeas should support both (it has both libpythonloader and libpython3loader). Is it really dependent on the host application?
Comment by Joschka Thurner (jthurner) - Tuesday, 30 April 2013, 10:23 GMT

Loading...