Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28265 - [python-markdown] Conflict with python2-markdown

Attached to Project: Community Packages
Opened by Julien Nicoulaud (nicoulaj) - Sunday, 05 February 2012, 11:50 GMT
Last edited by Kyle Keen (keenerd) - Wednesday, 14 March 2012, 22:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Both python-markdown and python2-markdown provide /usr/bin/markdown_py, but they are not marked as conflicting. A better solution could be renaming /usr/bin/markdown_py to /usr/bin/markdown_py2 for the python2-markdown package, because there are use cases where people need to have both installed...

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
pacman -S python-markdown
pacman -S python2-markdown => fails
This task depends upon

Closed by  Kyle Keen (keenerd)
Wednesday, 14 March 2012, 22:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2.1.1-3
Comment by Julien Nicoulaud (nicoulaj) - Sunday, 05 February 2012, 11:53 GMT
(Some more contextual information here: https://aur.archlinux.org/packages.php?ID=54924)
Comment by Kyle Keen (keenerd) - Wednesday, 14 March 2012, 21:45 GMT
Strange, this did not used to be a problem. Seems to have happened around when python-markdown2 was renamed python2-markdown. The old one used /usr/bin/markdown2, but markdown_py2 would be a better name for it.

Loading...