Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#28221 - [texlive-bin] version 2011.3-1.1 breaks xetex with "Fatal format file error; I'm stymied"

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Thursday, 02 February 2012, 08:29 GMT
Last edited by Gaetan Bisson (vesath) - Friday, 03 February 2012, 01:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture x86_64
Severity Critical
Priority Urgent
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Running xetex from texlive-bin-2011.3-1.1 on any document fails as this simple example shows:

$ xetex
This is XeTeX, Version 3.1415926-2.3-0.9997.5 (TeX Live 2012/dev/Arch Linux)
restricted \write18 enabled.
**\documentclass{article}
(Fatal format file error; I'm stymied)

Downgrading texlive-bin does not appear to solve the problem.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Friday, 03 February 2012, 01:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  texlive-bin-2011.3-1.2 in [extra]
Comment by Gaetan Bisson (vesath) - Thursday, 02 February 2012, 08:34 GMT
Downgrading texlive-bin to 2011.3-1 *and* zlib to 1.2.5-4 fixes this issue though.
Comment by Rémy Oudompheng (remyoudompheng) - Thursday, 02 February 2012, 21:43 GMT
I can't explain the issue. Maybe xetex is hacking into zlib's internals. I suggest I staticaly link with supplied zlib to avoid issues. The code is too sensitive to try any experiments.
Comment by Rémy Oudompheng (remyoudompheng) - Thursday, 02 February 2012, 22:11 GMT
The PKGBUILD needs large changes for that. Tell me whenever you find another solution.
Comment by Gaetan Bisson (vesath) - Thursday, 02 February 2012, 22:29 GMT
Alright; thanks for having a look.
Comment by Kamil Stachowski (caminoix) - Thursday, 02 February 2012, 22:38 GMT
Please ignore. My mistake, sorry.
Comment by Rémy Oudompheng (remyoudompheng) - Friday, 03 February 2012, 00:35 GMT
testing is also affected. I'm uploading packages for [extra] only. Will do testing later.
Comment by Rémy Oudompheng (remyoudompheng) - Friday, 03 February 2012, 00:46 GMT
Gaëtan: can you try texlive-bin 2011.3-1.2 and close the issue if OK ?
Comment by Gaetan Bisson (vesath) - Friday, 03 February 2012, 00:57 GMT
It works great Rémy; thanks a lot for the quick fix!

Loading...