Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#18904 - [gtk2] pcmanfm / thunar don't react on mouse in detail view

Attached to Project: Arch Linux
Opened by cl10k (cl10k) - Thursday, 01 April 2010, 11:34 GMT
Last edited by Jürgen Hötzel (juergen) - Thursday, 08 July 2010, 06:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jürgen Hötzel (juergen)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 60
Private No


When starting pcmanfm or thunar in detail view you can only open a folder once(!) - afterwards no mouse clicks are recognized
you can't open or select any other folders or files. The top-menu (files, edit,...) and the tool buttons still work.

The problem doesn't occur when you use the keyboard to navigate and launch your files!
(without using the mouse once!)

The problem doesn't occur when you change from detail view to symbol view. Then you can freely use the mouse to navigate and launch.

Problem occurs since pacman -Syu on 01.04.2010, pacman.log is attached...

Additional info:
* package version(s):
thunar: 1.0.1-5
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Thursday, 08 July 2010, 06:21 GMT
Reason for closing:  Fixed
Comment by JustcOne (JustcOne) - Thursday, 01 April 2010, 11:50 GMT
I have the exact same issue with pcmanfm and pcmanfm2 (pcmanfm-git from AUR).
Comment by baurzhan.m (cray) - Thursday, 01 April 2010, 14:16 GMT
I have the same issue with thunar.
My pacman log is attached

My pacman.log and log from first message have same packages

Comment by Mihai Militaru (akephalos) - Thursday, 01 April 2010, 14:28 GMT
I have the same problem. As a possible clue(?), the moment I updated, my lxterminal began to crash (segfault), reaching "cairo_xlib_surface_get_width" in valgrind. Now I can't reproduce or trace the bug anymore (I cleaned-up the system uninstalling many packages) then after reinstalling lxterminal it works fine.
Comment by KingX (KingX) - Friday, 02 April 2010, 04:13 GMT
FIXED: The error is caused by gtk2-2.20.0-1, I had to downgrade the following packages to facilitate the downgrade of gtk2. After the downgrade Thunar is working normally. :)

[2010-04-01 20:59] upgraded pygtk (2.17.0-1 -> 2.16.0-2)
[2010-04-01 20:59] upgraded pygobject (2.21.1-1 -> 2.20.0-1)
[2010-04-01 21:01] upgraded libidl2 (0.8.14-1 -> 0.8.13-1)
[2010-04-01 21:03] upgraded vte (0.24.0-1 -> 0.22.5-1)
[2010-04-01 21:03] upgraded librsvg (2.26.2-1 -> 2.26.0-2)
[2010-04-01 21:04] upgraded libwnck (2.30.0-1 -> 2.28.0-1)
[2010-04-01 21:04] upgraded gtk2 (2.20.0-1 -> 2.18.9-2)
Comment by Krishnan (kgas) - Friday, 02 April 2010, 09:07 GMT
This seems to be an odd issue. Out of 3 laptops in two no problem with the updates. In one the issues mentioned here are there. The difference is use of cairo-lcd. Even reverting back to the packages from official repo the problem exists.
Comment by Kel Varnsen (Varnsen) - Friday, 02 April 2010, 17:33 GMT
Same here. My pacman.log is identical to the ones posted here. I also thought it was because I had cairo-lcd so I quickly installed the original cairo package but the problem remained.

I'd rather wait for an fix update than downgrading. At least it still works on other view modes.
Comment by LX (gimmeapill) - Friday, 02 April 2010, 21:32 GMT
Same here on 2 machines with a similar config
Comment by Krishnan (kgas) - Saturday, 03 April 2010, 10:21 GMT
I confirm this bug.It is there on both 32 bit and 64 bit version.cairo-lcd is not the culprit.
Comment by Anton (zhuravlik) - Saturday, 03 April 2010, 13:14 GMT
Had the same issue with latest svn revision of pcmanfm1.
With latest git revision of pcmanfm2 there is no such problem.

(Both packages were rebuilded after gtk upgrade.)
Comment by Denis Sychjov (zic422) - Saturday, 03 April 2010, 13:50 GMT
I think that also have this issue. I noticed that I just cannot select file even with arrow keys. In place of blue selection there is a dot lined frame.
Comment by Carlos (Armadillux) - Saturday, 03 April 2010, 13:52 GMT
Dito, same problem opening folders in Detail- view!
Comment by David Bluecame (david.bluecame) - Saturday, 03 April 2010, 15:23 GMT
Hello, All.

From a totally updated system (after pacman -Syu right now), I have downgraded *only* the GTK2 package with "pacman -Ud gtk2-2.18.9-2-i686.pkg.tar.xz" within the package cache folder.

After this Thunar works perfectly.

I know this is not a solution because I have a lot of broken dependencies now, but I wanted to isolate which exact package was the responsable. I hope this can help tracking down the problem between GTK2 and Thunar

Best regards! David.
Comment by David Bluecame (david.bluecame) - Saturday, 03 April 2010, 15:42 GMT
The problem is in the file:


I have upgraded my system again with pacman -Syu and Thunar works bad again.

After that I have copied the file from the gtk2-2.18.9-2 package to my current /usr/lib/ folder. Now thunar works fine.

So, please check in the file what could be causing this issue. At least I think it will be more easy to the experts track down the problem now.

Best regards. David.
Comment by Masato Hashimoto (hashimo) - Saturday, 03 April 2010, 16:07 GMT
IMHO, this issue is same as follows:
Comment by C Smith (senshikaze) - Thursday, 08 April 2010, 01:53 GMT
same problem here. Upgraded gtk2 this morning.

[2010-04-07 07:05] upgraded gtk2 (2.18.9-2 -> 2.20.0-1)
Comment by Pierre Schmitz (Pierre) - Thursday, 08 April 2010, 17:42 GMT
assigning to thunar, pcmanfm and gtk2 maintainers.
Comment by Heiko Baums (cyberpatrol) - Saturday, 10 April 2010, 21:41 GMT
At least after the last system update which seemed to have some gtk2 and gnome related packages updated I found a change in this behaviour in thunar. Now this happens only if a directory is changed by double clicking it in the file list. If directories are changed by clicking onto the arrows in front of the directory name or by clicking once onto the directory name in the directory tree then files can be opened again by double clicking them in the file list. But if a directory is then double clicked the problem appears again.
Comment by François (mentat) - Monday, 12 April 2010, 07:21 GMT
Same bug, I confirm Heiko Baums report and if you want to select again a file, you can switch to icons view and come back to detail view until the next double click.

The downgrade to gtk2-2.18.9-2-i686.pkg.tar.xz the gtk broke my gtk theme.
Comment by Ivan (finarfin) - Tuesday, 13 April 2010, 07:51 GMT
i have the same problem with pcmanfm.
Now after last upgrades, i noticed that if i use keyboard to navigate through directories, everything works fine. The problem is only with mouse clicking.
Comment by Adam Hani Schakaki (krzd) - Monday, 19 April 2010, 20:56 GMT
Could someone please upload the old gtk2 package without to AUR or somewhere, because this bug is very annoying. I think other users would be also happy for now.

Thanks in advance
Comment by Michael (micele) - Tuesday, 20 April 2010, 13:57 GMT
same thing here. downgrade is not an option since there are already to much dependencies on gtk2>=2.20.0
Comment by Adam Hani Schakaki (krzd) - Tuesday, 20 April 2010, 19:28 GMT
Sure, but it is an option for me (two pcs) since I am using openbox and got no dependencies to gtk2>=2.20.0, only a few to gtk2 which will work with a lower version.
So I would be very happy if I could get an older version of gtk2.
Comment by IgnorantGuru (IgnorantGuru) - Tuesday, 20 April 2010, 19:34 GMT
the older gtk package should be available in ARM...
Comment by Bill (QuimaxW) - Tuesday, 20 April 2010, 19:46 GMT
I personally just install kdebase-dolphin (heresy, I know) since I already have the core kde packages for other QT based apps. I'm using that until this Thunar quirk is solved.
Comment by Bill (QuimaxW) - Tuesday, 20 April 2010, 21:11 GMT
I personally just install kdebase-dolphin (heresy, I know) since I already have the core kde packages for other QT based apps. I'm using that until this Thunar quirk is solved.
Comment by IgnorantGuru (IgnorantGuru) - Wednesday, 21 April 2010, 01:46 GMT
I added some additional info here...

At least in pcmanfm, it seems to be exo_noop_false that's doing it.
Comment by ok (OK100) - Saturday, 08 May 2010, 07:16 GMT
I have same problem, but pcmanfm-git from AUR works for me with all updates.
Comment by sead (sead) - Tuesday, 11 May 2010, 11:24 GMT
I also have the same problem, but like OK100 it works with the git version.
Comment by Masato Hashimoto (hashimo) - Wednesday, 12 May 2010, 05:15 GMT

Sorry, above git commit link is wrong (master branch). The following is xfce-4.6 branch.
I use HEAD of xfce-4.6 branch, it works fine for me.
Comment by ok (OK100) - Wednesday, 12 May 2010, 14:01 GMT
This bug is in Xubuntu 10.04 livecd too.
Comment by Peter Avramucz (muczyjoe) - Wednesday, 12 May 2010, 20:03 GMT
Git diff (mentioned by hashimo) works great for me.
Update: I'm was wrong, the git diff didn't help...
Comment by Kinney Baughman (whatshisname) - Saturday, 15 May 2010, 22:36 GMT
Would love it if someone would post a link to a working version of "".

Thanks for the suggestion IgnorantGuru but I couldn't find it on .

While reading in another forum about this problem, I discovered a less annoying work-around than the Ctr1 - Ctrl2 jazz.

While in details mode, if you enter folders using the "enter" key instead of double-clicking, everything works.

At least it did for me using the latest install of Arch.
Comment by Mihai Militaru (akephalos) - Friday, 21 May 2010, 14:49 GMT
Ok, the dirty patch in the thread that Masato has posted works for me, for exo, the current version 0.3.106. I attach my build archive, if someone wants to apply it without hassle, until things get fixed in the repository.
Comment by Masato Hashimoto (hashimo) - Friday, 21 May 2010, 15:04 GMT
FYI again,
Xfce4.6.2 will be released in this weekend or next week (UTC).
This issue is fixed in it.
Comment by Andreas Radke (AndyRTR) - Saturday, 22 May 2010, 17:41 GMT
packages are online. can you confirm if it is solved?
Comment by cl10k (cl10k) - Saturday, 22 May 2010, 18:42 GMT
@ AndyRTR & hashimo:

The bug is solved in Thunar 1.0.2-1 !
Comment by Heiko Baums (cyberpatrol) - Saturday, 22 May 2010, 18:42 GMT
The bug is fixed with the new packages.
Comment by sead (sead) - Saturday, 22 May 2010, 19:31 GMT
Is this bug only solved for thunar, for me there is no new packages for pcmanfm, or my mirror is not fully synchronized yet?
Comment by Heiko Baums (cyberpatrol) - Monday, 24 May 2010, 17:11 GMT
It's closed too early, because it's only fixed in thunar, but not in pcmanfm 0.5.2-1 as sead already mentioned.
Comment by Heiko Baums (cyberpatrol) - Monday, 24 May 2010, 17:46 GMT
Btw., pcmanfm 0.5.2-1 is outdated anyway (already flagged as out-of-date). But I don't know if the new version 0.9.5 fixes this bug.
Comment by Mihai Militaru (akephalos) - Monday, 24 May 2010, 18:33 GMT
Today I tested the old version in 'extra' and the bug is still there. Then I built the new version with the aur libfm - - and the ABS modified build file, and the bug is not there anymore - in 'details' view double click works normally.
...and it looks great, can't wait for the package (mine kinda crashes) :P.
Comment by Jürgen Hötzel (juergen) - Monday, 24 May 2010, 19:16 GMT
Sorry for the long delay.

I'm just preparing new libfm/pcmanfm packages. Please stay tuned.
Comment by J.-M. A. (moere) - Tuesday, 15 June 2010, 17:58 GMT
It is still not fixed, is it?

Pls fix this!!
Comment by David Bluecame (david.bluecame) - Tuesday, 15 June 2010, 19:44 GMT
It's already fixed in the last version of Thunar and dependent packages.

Best regards. David.
Comment by J.-M. A. (moere) - Tuesday, 15 June 2010, 19:52 GMT
Hm I should habe mentioned that I would be happy to see this fixed for pcmanfm.

It is not yet fixed for pcmanfm is it?
Comment by IgnorantGuru (IgnorantGuru) - Tuesday, 15 June 2010, 20:02 GMT
AFAIK this bug has not been fixed per se, but workarounds have been implemented for some apps and possibly in exo. Thunar is reported to work correctly now. pcmanfm2 (pcmanfm-git in AUR, aka version 0.9) includes a workaround. The stable pcmanfm (0.5.2) is abandoned and likely will not be fixed for this, unless the upstream bug in GTK is fixed. pcmanfm-mod (AUR), a minor fork of 0.5.2, includes a workaround...
Comment by David Bluecame (david.bluecame) - Tuesday, 15 June 2010, 20:03 GMT
You are right. At least in the latest pcmanfm 0.5.2-1 in the "testing" repository it's still not fixed. I have not tried to compile the latest development version, so I don't know if in that version is fixed or not.

It's sad that pcmanfm seems not to be so regularly mantained by it's developer. Also the absurd lack of recycle bin makes it not suitable for me. If it had a bin and better bugfixes pcmanfm would be the greatest file manager (just my opinion).

Best regards, and patience! ;-)
Comment by David Bluecame (david.bluecame) - Tuesday, 15 June 2010, 20:10 GMT
By the way, I have gone to the pcmanfm page and it seems that pcmanfm developer is not mantaining the stable version because he has completely rewritten the entire pcmanfm application!! :-O So as IgnorantGuru says, the brand new version will have workarounds for this bug and ALSO a recycle bin ¡at last!. When this version goes to testing, I'm probably switch from Thunar to pcmanfm :-))

Best regards! David.
Comment by IgnorantGuru (IgnorantGuru) - Tuesday, 15 June 2010, 20:19 GMT
The dev (PCMan) moved on to his rewrite aka pcmanfm2, which leaves pcmanfm 0.5.2 unmaintained. But v2 is still in heavy dev, so yeah, there is a support gap there. The dev comments on some of the issues in this thread

Comment by J.-M. A. (moere) - Tuesday, 15 June 2010, 21:22 GMT
thanks a lot for the info!

I installed the modified version now!

Thx IgnorantGuru.
Comment by sead (sead) - Wednesday, 16 June 2010, 11:35 GMT
I installed the pcmanfm-mod but I still have the same problem. Is this version supposed to fix the problem?
Comment by J.-M. A. (moere) - Wednesday, 16 June 2010, 12:24 GMT
sead you need to kill all running pcmanfm´s that are running.
(Ur desktop has one running, too)
ps -a
kill "pid of the pcmanfm"

or just logout and login again
or reboot
Comment by IgnorantGuru (IgnorantGuru) - Wednesday, 16 June 2010, 20:32 GMT
J.-M. A. is correct - also make sure you are running the mod (it may be installed as pcmanfm or pcmanfm-mod depending on install method). The Help|About window should show the mod version number.

Also, I released an update today which adds a few things. You can subscribe to the thread below to be notified of updates, or to post any other questions...
Comment by Jürgen Hötzel (juergen) - Wednesday, 07 July 2010, 16:47 GMT
I just moved the new libfm-based PCManFM to extra-*. Please check it out.
Comment by Krishnan (kgas) - Thursday, 08 July 2010, 04:09 GMT
Checked and the detailed list view behaves as intended. Thanks juergen