Arch Linux

Your vote could not be removed at this time.
Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48632 - [libreoffice-fresh] Cannot copy paste between libreoffice documents

Attached to Project: Arch Linux
Opened by Ferenc Sipos (frankieboy) - Saturday, 19 March 2016, 13:13 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 23 March 2016, 18:30 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I'd like to copy some text from one document into another, but when I click on paste, or press ctrl+v nothing happens.

Additional info:
* package version(s)
* config and/or log files etc.
Libreoffice 5.1.1-1
gnome with wayland (but I can reproduce the error with X11)

Steps to reproduce:
Open two new documents, type some text than copy it, and try to paste it into the other document.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 23 March 2016, 18:30 GMT
Reason for closing:  Upstream
Additional comments about closing:  I'm cc'ed to the upstream bug.
Comment by Doug Newgard (Scimmia) - Saturday, 19 March 2016, 15:07 GMT
Sound like a GNOME issue. Have you tried it anywhere else?
Comment by Andreas Radke (AndyRTR) - Saturday, 19 March 2016, 15:38 GMT
Works here for me with i3-wm. This should be assigned to Gnome maintainers.
Comment by Alois Nespor (anespor) - Wednesday, 23 March 2016, 06:21 GMT
upstream bug, bug in GTK3 VCL in libreoffice, because after uncomment "export SAL_USE_VCLPLUGIN=gtk"
in /etc/profile.d/libreoffice-fresh.sh (also switching to GTK2 UI) copy-paste works.

https://bugs.documentfoundation.org/show_bug.cgi?id=98831

Loading...