Community Packages

Your vote could not be added at this time.
Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71092 - [steam-native-runtime] Steam hangs at login

Attached to Project: Community Packages
Opened by Jonny Robbie (JonnyRobbie) - Wednesday, 02 June 2021, 14:14 GMT
Last edited by Maxime Gauduin (Alucryd) - Wednesday, 09 June 2021, 07:22 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Levente Polyak (anthraxx)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
Steam native stopped working a few system updates ago. I don't know for certain when, because it is probably a dependency issue as the steam-native-runtime hasn't updated in a month or two and it definitely worked a few weeks ago.

Additional info:
* package version steam-native-runtime 1.0.0.70-1

Steps to reproduce:
Run `steam-native` and log-in.
The steam will hang on the "Connecting to Steam account: username" window. Sometimes with the progress bar, sometimes without.
Running `steam-runtime` works fine.

Attached is the process stdout.
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Wednesday, 09 June 2021, 07:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.0.0.70-2
Comment by Jonny Robbie (JonnyRobbie) - Wednesday, 02 June 2021, 14:15 GMT
There's an arch forum thread which might provide a bit more info: https://bbs.archlinux.org/viewtopic.php?pid=1975778
Comment by Jonathon (jonathon) - Wednesday, 02 June 2021, 16:04 GMT
Can confirm I'm seeing the same thing. Log/terminal output has a lot of:

```
src/clientdll/appdatacache.cpp (2679) : Assertion Failed: !bSharedKVSymbols
```

From some searching, there are some old (~2017) threads that mention this as an issue with different/unexpected library versions.
Comment by Neros (Neros) - Monday, 07 June 2021, 22:11 GMT
Steam has been updated today (stable branch)(https://store.steampowered.com/oldnews/85088) and now I'm in the same situation with the same errors as @jonathon.
Comment by daaelar (daaelar) - Tuesday, 08 June 2021, 02:42 GMT
This bug happens because steam is looking for libnm.so.2 in a 32 bit path. This library doesn't seem to be available in lib32 on Arch. It's not occurring if using the steam runtime.

pushd ~/.steam/root/ubuntu12_32; file * | grep ELF | cut -d: -f1 | LD_LIBRARY_PATH=. xargs ldd | grep 'not found' | sort | uniq; popd
~/.steam/root/ubuntu12_32 ~
libnm.so.0 => not found
~
Comment by Dragoon Aethis (DragoonAethis) - Tuesday, 08 June 2021, 10:24 GMT
I modified the NetworkManager PKGBUILD to generate lib32-libnm, both source and a prebuilt package is attached. This most likely needs to be packaged officially as a dependency for steam-native-runtime.
Comment by Noah Kennedy (nomaxx117) - Tuesday, 08 June 2021, 18:11 GMT
Dragoon's PKGBUILD resolves the issue on my machine.
Comment by Norbert Fuksz (Fuxy) - Tuesday, 08 June 2021, 18:46 GMT
Still seems to fail for me after installing the lib32-libnm provided.

Edit: a `steam --reset` after the install seems to have made it work
Comment by Dragoon Aethis (DragoonAethis) - Tuesday, 08 June 2021, 18:56 GMT
Fuxy, can you check if any other libraries are missing on your system? Use commands from daaelar's comment above.
Comment by Norbert Fuksz (Fuxy) - Tuesday, 08 June 2021, 19:01 GMT
There is nothing missing `file * | grep ELF | cut -d: -f1 | LD_LIBRARY_PATH=. xargs ldd | grep 'not found' | sort | uniq` in ubuntu12_32 doesn't return anything missing.

as stated in my edit it seems it needed a `steam --reset` to make it start... wierd
Comment by Norbert Fuksz (Fuxy) - Tuesday, 08 June 2021, 19:07 GMT
Upon further inspection it boots just fine when reset and needing a login but crashes if creds are are already saved and auto logged in...

Seems to be related to this https://github.com/ValveSoftware/steam-for-linux/issues/7813
Comment by daaelar (daaelar) - Tuesday, 08 June 2021, 20:16 GMT
Fuxy, you might want to check your steam logs (~/.steam/root/logs) and find the error causing this, or run steam directly (steam-native) and watch the output to look for an error. Using DragoonAethis' lib32-libnm package I was able to login successfully, and I have credentials saved.
Comment by Jouni Rinne (cyberpunkrocker) - Wednesday, 09 June 2021, 03:57 GMT
If the new Steam client now requires lib32-libnm, the legacy libnm-glib and lib32-libnm-glib packages can probably now be dropped from dependencies?

Loading...