Community Packages

Your vote could not be added at this time.
Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69500 - [sagemath] Import error for lrcalc library

Attached to Project: Community Packages
Opened by Simone (tigerjack) - Monday, 01 February 2021, 17:31 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 02 February 2021, 19:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Launching `sage` from terminal gives me the stacktrace reported in stacktrace1.
The same happens if I try to do a `from sage.all import *` from ipython, from a python file or from sage -python.

Additionally, if from an ipython module I invoke `from sage.misc.misc_c import prod`, everything works fine.
On the other hand, `from sage.rings.real_mpfr import RealField ` works well inside ipython, but produce an Import error if placed inside a source file (shown in stacktrace2)



Additional info:
* package version(s): 9.2-9
* config and/or log files: see attached stacktraces

Steps to reproduce:
Just launch sage from the terminal.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 02 February 2021, 19:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  sagemath 9.2-10
Comment by Antonio Rojas (arojas) - Monday, 01 February 2021, 18:01 GMT
Sorry for the inconvenience. For now, you can downgrade lrcalc to 1.2-4

Loading...