Arch Linux

Your vote could not be added at this time.
Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44344 - [gobject-introspection-runtime] GDM 3.16 not working

Attached to Project: Arch Linux
Opened by Nic (xenos) - Thursday, 26 March 2015, 08:03 GMT
Last edited by Jan de Groot (JGC) - Thursday, 06 August 2015, 11:08 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description: When attempting to start gdm after updating to the below version, it fails to start and leaves you at the console. I've read that gdm-3.16 uses xwayland by default, gnome with wayland worked fine with version 3.14. My setup is intel/nvidia with bumblebee (which I disabled to no avail).


Additional info:
* package version(s) 3.16.0.1-1-x86_64
* config and/or log files etc.

Mar 26 17:02:22 tardis gdm[764]: GdmDisplay: display lasted 0.238155 seconds
Mar 26 17:02:22 tardis gdm[764]: Child process 799 was already dead.
Mar 26 17:02:22 tardis gdm[764]: Unable to kill session worker process
Mar 26 17:02:22 tardis gdm[764]: Child process 799 was already dead.
Mar 26 17:02:22 tardis gdm[764]: Unable to kill session worker process


Steps to reproduce: Enable testing repository, pacman -Syu, reboot or systemctl restart gdm
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 06 August 2015, 11:08 GMT
Reason for closing:  Works for me
Comment by Doug Newgard (Scimmia) - Thursday, 26 March 2015, 14:00 GMT
What does your xorg log look like?
Comment by Chris (kitteboss) - Thursday, 26 March 2015, 20:50 GMT
Got the same problem here, journalctl gives following error a few lines earlier:

gnome-shell: error while loading shared libraries: libgirepository-1.0.so.1: cannot open shared object file: No such file or directory

For me manually reinstalling pacman -S gobject-introspection-runtime solved the problem.
Comment by Theodor van Nahl (tvn87) - Thursday, 26 March 2015, 22:15 GMT
On my system (intel graphics) I have the same problem. I cannot confirm the problem with gobject-introspection-runtime since I updated gobject-introspection before testing/gnome.

The attached log file I created by starting gdm manually in debug mode.
   gdm.log (51.6 KiB)
Comment by Nic (xenos) - Thursday, 26 March 2015, 22:55 GMT
Thank you kitteboss, reinstalling gobject-introspection-runtime solved the problem.
Comment by Doug Newgard (Scimmia) - Friday, 27 March 2015, 04:10 GMT
Wait a minute, are you guys talking about simply reinstalling the same version? That doesn't make sense!
Comment by Chris (kitteboss) - Friday, 27 March 2015, 06:48 GMT
Yes, we are saying exactly that! I noticed that after the update in my /usr/lib/ there was no libgirepository-1.0.so.1, which should be installed by gobject-introspection-runtime, which itself is a dependency for gobject-introspection. So I first tried to simply reinstall gobject-introspection wihtout success, only manually reinstalling gobject-introspection-runtime solved the problem. Is there mabye a problem in the pkg?
Comment by Chris (kitteboss) - Friday, 27 March 2015, 08:42 GMT
Ok, I've looked at the pkgs and everything seems fine to me. Also removing the gobject-introspection-runtime and reinstalling it works without any complications. I'm not able to reproduce the problem. It seems that during the upgrade something resulted in not installing the gobject-introspection-runtime pkg correctly. At least in my case... :)
Comment by Theodor van Nahl (tvn87) - Friday, 27 March 2015, 09:35 GMT
Solved mine, too. Had [testing] after [core] and [extra], which has been a recommendation on G+.
Comment by Jan de Groot (JGC) - Friday, 27 March 2015, 13:49 GMT
This is not a packaging bug, but an issue with pacman or some wrapper.

Somehow when files move from one package to another files will get lost. I don't know if this is a bug in pacman or the way people use it. Personally I never hit this problem myself, but if you use pacman -Sf to install gobject-introspection-runtime and then later upgrade gobject-introspection you'll run into missing files.
Comment by Chris (kitteboss) - Friday, 27 March 2015, 14:01 GMT
Ok, good to know for future troubles :) . Thanks
Comment by step-2 (step-2) - Sunday, 29 March 2015, 15:07 GMT
same problem here solved by reinstalling gobject-introspection from extra
Comment by Jan de Groot (JGC) - Tuesday, 31 March 2015, 15:02 GMT
I would like to see pacman.log files for people affected by this.
Comment by krabador (krabador) - Friday, 10 April 2015, 04:25 GMT
I can confirm that after gnome 3.16 update, black screen and not a gdm running, because of "error while loading shared libraries: libgirepository-1.0.so.1: cannot open shared object file: No such file or directory. Uninstallation and installation of gobject-introspection not solved, uninstallation and reinstallation of gobject-introspection-runtime solved the issue. Before reinstallation of gobject-introspection-runtime , pacman -Ql gobject-introspection-runtime, listed the libgirepository present in /usr/lib/libgirepository-1.0.so , as later the reinstallation.

Extract of journalctl -b

5:49:29 gnome-session[278]: gnome-shell: error while loading shared libraries: libgirepository-1.0.so.1: cannot open shared object file: No such file or directory

Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 12:34 GMT
I am not using testing repos and however after the update i got the same problem
Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 13:29 GMT
I tried reinstalling both gobject-introspection and runtime in both orders and still have the problem
Comment by Chris (kitteboss) - Friday, 10 April 2015, 16:15 GMT
@guilhermemtr Hi, have you checked if you have the same problem, what does your journalctl say? Is libgirepository present in your /usr/lib/ directory?
Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 16:18 GMT
i have the file present in the /usr/lib directory.
I might be a xorg conf problem, but i have no clue unfortunently. im using a nvidia proprietary driver
Comment by Chris (kitteboss) - Friday, 10 April 2015, 16:22 GMT
Do you get some error info from systemctl or dmesg or Xorg.log?
Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 17:50 GMT
i am getting a segfault (error 4) in libX11.so.6.3.0
Comment by Chris (kitteboss) - Friday, 10 April 2015, 19:03 GMT
Sounds like it might have to be more related to bug  FS#44531 
Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 19:05 GMT
thank you so much for the redirection, i hadnt found it yet. it looks like to me that it is actually the problem (i mean, the bug). cheers

Loading...