Arch Linux

Your vote could not be added at this time.
Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#40171 - [linux] 3.14.2-1 built with gcc from testing repo

Attached to Project: Arch Linux
Opened by Fredrik Blom (Blom) - Thursday, 01 May 2014, 12:01 GMT
Last edited by Allan McRae (Allan) - Friday, 02 May 2014, 08:45 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Allan McRae (Allan)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 38
Private No


It seems that linux-3.14.2-1 in the core repo is built with gcc (4.9.0) to be able to utilize the -fstack-protector-strong compiler flag. This of course causes problems for us who wish to compile our own modules against the kernel, since gcc from the core repo is still at version 4.8.2.

Additional info:
* core/linux-3.14.2-1
* core/gcc-4.8.2-8

Steps to reproduce:
1. Download the broadcom-wl tarball from
2. Extract, run makepkg
3. Output:
make: Entering directory '/usr/lib/modules/3.14.2-1-ARCH/build'
Makefile:615: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 02 May 2014, 08:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  gcc-4.9 in [core]
Comment by Daniel Hillenbrand (codeworkx) - Thursday, 01 May 2014, 16:51 GMT
Critical! :-D
I'm without my wifi module now.
Happy that android supports tethering.
Comment by Pablo Lezaeta (Jristz) - Thursday, 01 May 2014, 20:49 GMT
I have the same problem with stock kms modules in stable repo in i686