Arch Linux

Your vote could not be added at this time.
Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33456 - [amarok] needs liblastfm 1.x

Attached to Project: Arch Linux
Opened by Antonio Rojas (arojas) - Saturday, 19 January 2013, 12:29 GMT
Last edited by Andrea Scarpino (BaSh) - Friday, 25 January 2013, 14:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 23
Private No


Amarok 2.7 doesn't support liblastfm 0.x, it needs version 1.x. So, either liblastfm should be updated and amarok rebuilt or support should be removed and the liblastfm dependency dropped. In case the first option is chosen, there's a patch from Mageia to make clementine (the only other package in the repos using it) compile against liblastfm 1.x
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Friday, 25 January 2013, 14:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  amarok 2.7.0-2
Comment by phanisvara das (phani00) - Saturday, 19 January 2013, 13:32 GMT
confused: how comes i'm listening to amarok 2.7.0-1, with liblstfm 0.3.3-3 on my system (arch +testing +kde-unstable)?
Comment by phanisvara das (phani00) - Saturday, 19 January 2013, 15:01 GMT
ah, of course: lastfm isn't there in the new amarok!
Comment by Doug Newgard (Scimmia) - Wednesday, 23 January 2013, 21:57 GMT
In summary, problem is that liblastfm is out of date. You DO NOT report out of date packages as bugs.
Comment by Antonio Rojas (arojas) - Wednesday, 23 January 2013, 22:02 GMT
No, the problem is that amarok depends on an incompatible version of liblastfm. This bug is filed against amarok, not liblastfm.