diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD
index 5118faa..70be63f 100644
--- a/trunk/PKGBUILD
+++ b/trunk/PKGBUILD
@@ -8,7 +8,7 @@
 # Contributor: Caleb Maclennan <caleb@alerque.com>
 
 pkgname=gitlab
-pkgver=15.11.0
+pkgver=16.0.0
 pkgrel=1
 pkgdesc="Project management and code hosting application"
 arch=('x86_64')
@@ -27,6 +27,7 @@ backup=("etc/webapps/gitlab/database.yml"
         "etc/webapps/gitlab/smtp_settings.rb"
         "etc/logrotate.d/gitlab")
 source=(git+https://gitlab.com/gitlab-org/gitlab-foss.git#tag=v$pkgver
+        https://gitlab.com/gitlab-org/gitlab/-/commit/5b9062832119599bf31ecca35e8fea74a9c1fe24.patch
         configs.patch
         fixes.patch
         environment
@@ -44,7 +45,8 @@ conflicts=('gitlab-workhorse')
 replaces=('gitlab-workhorse')
 install='gitlab.install'
 sha512sums=('SKIP'
-            '504ab3130f8465521e0eeca8a9885ad04bec01933f71637cd439faaa5b0be783a3e8f48f0337d41e36f2de40d94b3771747684bb3eada63a073f5f9c1d38ad22'
+            'd56190e26fa52cdbe861492d2f2da0bd891d149b60fd914652620be03dc2052c583771114dd749140bfd22553e79eb9b563cbd5e6296a7019fc291dbc9f36dc0'
+            'eccb0e1ca6601f7b9a6d102e63cc082b7c9defaa698f14ff5c2f01179f723dcbd34c62424d24202bf05cbf9468a8f787bc9f0fd6f76df79e42bc805bf40f3e03'
             '7384a7cb995832be3643e1f8b16f9454c6ef04ff1e0dc1a3aed3ad849d11d0be7f573c024c4d867d69e726fceccea1a58c9c3074ef166291b8357b3fc30922a8'
             '5b1ca2958f03a5baf1c5576a1568072e8ed749e2d15745ecbcc4860d2dbd543f2f3ed077e8d87afac2670c9436b19fe498217b49916d56a4e31fb9811aeb9067'
             '451a030940f124bccd6d29c1924861b361d52db32cff6e745c144286c2afc7065e117f825721145ed2dd4406f5bcfa97e228a80b968aaa9a675613b71b776eba'
@@ -65,6 +67,8 @@ _logdir="/var/log/gitlab"
 
 prepare() {
   cd gitlab-foss
+  # Update grpc gem to v1.54.2 needed to build with gcc 13
+  patch -Np1 -i ../5b9062832119599bf31ecca35e8fea74a9c1fe24.patch
 
   # GitLab tries to read its revision information from a file.
   git rev-parse --short HEAD > REVISION
diff --git a/trunk/configs.patch b/trunk/configs.patch
index 90e8466..9e405c5 100644
--- a/trunk/configs.patch
+++ b/trunk/configs.patch
@@ -15,7 +15,7 @@ Date:   Tue May 26 00:01:38 2020 -0700
     will cause a conflict that needs to be reviewed manually.
 
 diff --git a/config/database.yml.postgresql b/config/database.yml.postgresql
-index c1b1247b5b08..19c33fdd1f56 100644
+index b210b9c412b..da231c6153e 100644
 --- a/config/database.yml.postgresql
 +++ b/config/database.yml.postgresql
 @@ -6,7 +6,7 @@ production:
@@ -23,7 +23,7 @@ index c1b1247b5b08..19c33fdd1f56 100644
      encoding: unicode
      database: gitlabhq_production
 -    username: git
-+    username: gitlab
++    username: gitlib
      password: "secure password"
      host: localhost
      # load_balancing:
@@ -31,14 +31,14 @@ index c1b1247b5b08..19c33fdd1f56 100644
      #     port: 8600
      #     record: secondary.postgresql.service.consul
      #     interval: 300
--  # ci:
--  #   adapter: postgresql
--  #   encoding: unicode
--  #   database: gitlabhq_production
--  #   database_tasks: false
--  #   username: git
--  #   password: "secure password"
--  #   host: localhost
+-  ci:
+-    adapter: postgresql
+-    encoding: unicode
+-    database: gitlabhq_production
+-    database_tasks: false
+-    username: git
+-    password: "secure password"
+-    host: localhost
 -  geo:
 -    adapter: postgresql
 -    encoding: unicode
@@ -53,16 +53,16 @@ index c1b1247b5b08..19c33fdd1f56 100644
      host: localhost
      variables:
        statement_timeout: 15s
--  # ci:
--  #   adapter: postgresql
--  #   encoding: unicode
--  #   database: gitlabhq_development
--  #   database_tasks: false
--  #   username: postgres
--  #   password: "secure password"
--  #   host: localhost
--  #   variables:
--  #     statement_timeout: 15s
+-  ci:
+-    adapter: postgresql
+-    encoding: unicode
+-    database: gitlabhq_development
+-    database_tasks: false
+-    username: postgres
+-    password: "secure password"
+-    host: localhost
+-    variables:
+-      statement_timeout: 15s
 -  geo:
 -    adapter: postgresql
 -    encoding: unicode
@@ -80,14 +80,14 @@ index c1b1247b5b08..19c33fdd1f56 100644
 -    username: git
 -    password: "secure password"
 -    host: localhost
--  # ci:
--  #   adapter: postgresql
--  #   encoding: unicode
--  #   database: gitlabhq_staging
--  #   database_tasks: false
--  #   username: git
--  #   password: "secure password"
--  #   host: localhost
+-  ci:
+-    adapter: postgresql
+-    encoding: unicode
+-    database: gitlabhq_staging
+-    database_tasks: false
+-    username: git
+-    password: "secure password"
+-    host: localhost
 -  geo:
 -    adapter: postgresql
 -    encoding: unicode
@@ -97,21 +97,21 @@ index c1b1247b5b08..19c33fdd1f56 100644
      password: "secure password"
      host: localhost
  
-@@ -106,21 +59,3 @@ test: &test
+@@ -106,28 +59,3 @@ test: &test
      prepared_statements: false
      variables:
        statement_timeout: 15s
--  # ci:
--  #   adapter: postgresql
--  #   encoding: unicode
--  #   database: gitlabhq_test
--  #   database_tasks: false
--  #   username: postgres
--  #   password:
--  #   host: localhost
--  #   prepared_statements: false
--  #   variables:
--  #     statement_timeout: 15s
+-  ci:
+-    adapter: postgresql
+-    encoding: unicode
+-    database: gitlabhq_test
+-    database_tasks: false
+-    username: postgres
+-    password:
+-    host: localhost
+-    prepared_statements: false
+-    variables:
+-      statement_timeout: 15s
 -  geo:
 -    adapter: postgresql
 -    encoding: unicode
@@ -119,8 +119,15 @@ index c1b1247b5b08..19c33fdd1f56 100644
 -    username: postgres
 -    password:
 -    host: localhost
+-  embedding:
+-    adapter: postgresql
+-    encoding: unicode
+-    database: gitlabhq_embedding_test
+-    username: postgres
+-    password:
+-    host: localhost
 diff --git a/config/gitlab.yml.example b/config/gitlab.yml.example
-index e8a88628a8ac..44bae1866848 100644
+index e46bc5b646c..359bcded5da 100644
 --- a/config/gitlab.yml.example
 +++ b/config/gitlab.yml.example
 @@ -91,7 +91,7 @@ production: &base
@@ -152,7 +159,7 @@ index e8a88628a8ac..44bae1866848 100644
      # File location to read encrypted SMTP secrets from
      # email_smtp_secret_file: /mnt/gitlab/smtp.yaml.enc # Default: shared/encrypted_settings/smtp.yaml.enc
  
-@@ -167,7 +167,7 @@ production: &base
+@@ -168,7 +168,7 @@ production: &base
      ## Repository downloads directory
      # When a user clicks e.g. 'Download zip' on a project, a temporary zip file is created in the following directory.
      # The default is 'shared/cache/archive/' relative to the root of the Rails app.
@@ -161,7 +168,7 @@ index e8a88628a8ac..44bae1866848 100644
  
      ## Impersonation settings
      impersonation_enabled: true
-@@ -234,7 +234,7 @@ production: &base
+@@ -235,7 +235,7 @@ production: &base
      # Since `mail_room` is run independently of Rails, an absolute path is preferred.
      # The default is 'log/mail_room_json.log' relative to the root of the Rails app.
      #
@@ -170,7 +177,7 @@ index e8a88628a8ac..44bae1866848 100644
  
      # If you are using Microsoft Graph instead of IMAP, set this to false to retain
      # messages in the inbox since deleted messages are auto-expunged after some time.
-@@ -269,7 +269,7 @@ production: &base
+@@ -270,7 +270,7 @@ production: &base
      # contains the shared secret key for verifying access for mailroom's
      # incoming_email.
      # Default is '.gitlab_mailroom_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -178,8 +185,8 @@ index e8a88628a8ac..44bae1866848 100644
 +    # secret_file: /var/lib/gitlab/.gitlab_mailroom_secret
  
      # File location to read encrypted incoming email secrets from
-     # encrypted_secret_file: /mnt/gitlab/smtp.yaml.enc 
-@@ -309,7 +309,7 @@ production: &base
+     # encrypted_secret_file: /mnt/gitlab/smtp.yaml.enc
+@@ -310,7 +310,7 @@ production: &base
    artifacts:
      enabled: true
      # The location where build artifacts are stored (default: shared/artifacts).
@@ -188,7 +195,7 @@ index e8a88628a8ac..44bae1866848 100644
      # object_store:
      #   enabled: false
      #   remote_directory: artifacts # The bucket name
-@@ -328,7 +328,7 @@ production: &base
+@@ -329,7 +329,7 @@ production: &base
      # be stored on disk, or in object storage
      enabled: false
      # The location where external diffs are stored (default: shared/lfs-external-diffs).
@@ -197,7 +204,7 @@ index e8a88628a8ac..44bae1866848 100644
      # object_store:
      #   enabled: false
      #   remote_directory: external-diffs
-@@ -343,7 +343,7 @@ production: &base
+@@ -344,7 +344,7 @@ production: &base
    lfs:
      enabled: true
      # The location where LFS objects are stored (default: shared/lfs-objects).
@@ -206,7 +213,7 @@ index e8a88628a8ac..44bae1866848 100644
      object_store:
        enabled: false
        remote_directory: lfs-objects # Bucket name
-@@ -383,7 +383,7 @@ production: &base
+@@ -384,7 +384,7 @@ production: &base
      enabled: true
      dpkg_deb_path: /usr/bin/dpkg-deb
      # The location where build packages are stored (default: shared/packages).
@@ -215,7 +222,7 @@ index e8a88628a8ac..44bae1866848 100644
      object_store:
        enabled: false
        remote_directory: packages # The bucket name
-@@ -402,7 +402,7 @@ production: &base
+@@ -403,7 +403,7 @@ production: &base
    dependency_proxy:
      enabled: true
      # The location where build packages are stored (default: shared/dependency_proxy).
@@ -224,7 +231,7 @@ index e8a88628a8ac..44bae1866848 100644
      object_store:
        enabled: false
        remote_directory: dependency_proxy # The bucket name
-@@ -421,7 +421,7 @@ production: &base
+@@ -422,7 +422,7 @@ production: &base
    terraform_state:
      enabled: true
      # The location where Terraform state files are stored (default: shared/terraform_state).
@@ -233,7 +240,7 @@ index e8a88628a8ac..44bae1866848 100644
      object_store:
        enabled: false
        remote_directory: terraform # The bucket name
-@@ -457,7 +457,7 @@ production: &base
+@@ -458,7 +458,7 @@ production: &base
      enabled: false
      access_control: false
      # The location where pages are stored (default: shared/pages).
@@ -242,7 +249,7 @@ index e8a88628a8ac..44bae1866848 100644
  
      # The domain under which the pages are served:
      # http://group.example.com/project
-@@ -471,7 +471,7 @@ production: &base
+@@ -472,7 +472,7 @@ production: &base
  
      # File that contains the shared secret key for verifying access for gitlab-pages.
      # Default is '.gitlab_pages_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -251,7 +258,7 @@ index e8a88628a8ac..44bae1866848 100644
      object_store:
        enabled: false
        remote_directory: pages # The bucket name
-@@ -662,7 +662,7 @@ production: &base
+@@ -663,7 +663,7 @@ production: &base
      # port: 5005
      # api_url: http://localhost:5000/ # internal address to the registry, will be used by GitLab to directly communicate with API
      # key: config/registry.key
@@ -260,7 +267,7 @@ index e8a88628a8ac..44bae1866848 100644
      # issuer: gitlab-issuer
      # notification_secret: '' # only set it when you use Geo replication feature without built-in Registry
  
-@@ -713,7 +713,7 @@ production: &base
+@@ -714,7 +714,7 @@ production: &base
      # Default project notifications settings:
  
      # The location where build traces are stored (default: builds/). Relative paths are relative to Rails.root
@@ -269,7 +276,7 @@ index e8a88628a8ac..44bae1866848 100644
  
    #
    # 3. Auth settings
-@@ -1179,7 +1179,7 @@ production: &base
+@@ -1167,7 +1167,7 @@ production: &base
  
    # Shared file storage settings
    shared:
@@ -278,7 +285,7 @@ index e8a88628a8ac..44bae1866848 100644
  
    # Encrypted Settings configuration
    encrypted_settings:
-@@ -1204,14 +1204,14 @@ production: &base
+@@ -1192,14 +1192,14 @@ production: &base
      # real path not the symlink.
      storages: # You must have at least a `default` storage path.
        default:
@@ -297,7 +304,7 @@ index e8a88628a8ac..44bae1866848 100644
      # archive_permissions: 0640 # Permissions for the resulting backup.tar file (default: 0600)
      # keep_time: 604800   # default: 0 (forever) (in seconds)
      # pg_schema: public     # default: nil, it means that all schemas will be backed up
-@@ -1246,12 +1246,12 @@ production: &base
+@@ -1234,12 +1234,12 @@ production: &base
  
    ## GitLab Shell settings
    gitlab_shell:
@@ -313,7 +320,7 @@ index e8a88628a8ac..44bae1866848 100644
  
      # Git over HTTP
      upload_pack: true
-@@ -1266,13 +1266,13 @@ production: &base
+@@ -1254,13 +1254,13 @@ production: &base
    workhorse:
      # File that contains the secret key for verifying access for gitlab-workhorse.
      # Default is '.gitlab_workhorse_secret' relative to Rails.root (i.e. root of the GitLab app).
@@ -329,7 +336,7 @@ index e8a88628a8ac..44bae1866848 100644
  
      # The URL to the external KAS API (used by the Kubernetes agents)
      # external_url: wss://kas.example.com
-@@ -1290,7 +1290,7 @@ production: &base
+@@ -1278,7 +1278,7 @@ production: &base
  
    ## GitLab Elasticsearch settings
    elasticsearch:
@@ -339,7 +346,7 @@ index e8a88628a8ac..44bae1866848 100644
    ## Git settings
    # CAUTION!
 diff --git a/config/puma.rb.example b/config/puma.rb.example
-index 59844b4aecff..0560d761e239 100644
+index d474fc70500..c6746a6a3d4 100644
 --- a/config/puma.rb.example
 +++ b/config/puma.rb.example
 @@ -5,11 +5,11 @@
@@ -374,8 +381,8 @@ index 59844b4aecff..0560d761e239 100644
  
  on_restart do
    # Signal application hooks that we're about to restart
-@@ -81,7 +81,7 @@ wait_for_less_busy_worker ENV.fetch('PUMA_WAIT_FOR_LESS_BUSY_WORKER', 0.001).to_
- nakayoshi_fork unless ENV['DISABLE_PUMA_NAKAYOSHI_FORK'] == 'true'
+@@ -85,7 +85,7 @@ if Gem::Version.new(Puma::Const::PUMA_VERSION).canonical_segments.first == 5 &&
+ end
  
  # Use json formatter
 -require_relative "/home/git/gitlab/lib/gitlab/puma_logging/json_formatter"